Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#17222 closed defect (fixed)

git-core 1.6.0.4_0: /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: unknown flag: -rpath

Reported by: ryandesign (Ryan Schmidt) Owned by: maccheck@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: bryan@…, blb@…, tobias.weisserth@…, simon@…
Port: git-core

Description

I can't upgrade git-core from 1.6.0.2_2 to 1.6.0.4_0 on Mac OS X 10.4.11 Intel with Xcode 2.5:

--->  Verifying checksum(s) for git-core
--->  Extracting git-core
--->  Applying patches to git-core
--->  Configuring git-core
--->  Building git-core
Error: Target org.macports.build returned: shell command " cd "/mp/var/macports/build/_Users_rschmidt_macports_dports_devel_git-core/work/git-1.6.0.4" && nice -n 10 make all CFLAGS="-Wall -O2 -I/mp/include" LDFLAGS="-L/mp/lib" prefix=/mp CURLDIR=/mp OPENSSLDIR=/mp ICONVDIR=/mp PERL_PATH="/mp/bin/perl" NO_FINK=1 NO_DARWIN_PORTS=1 NO_R_TO_GCC_LINKER=1 " returned error 2
Command output:     CC tree-diff.o
    CC tree.o
    CC tree-walk.o
    CC unpack-trees.o
    CC usage.o
    CC utf8.o
utf8.c: In function 'reencode_string':
utf8.c:363: warning: passing argument 2 of 'libiconv' from incompatible pointer type
    CC walker.o
    CC wrapper.o
    CC write_or_die.o
    CC ws.o
    CC wt-status.o
    CC xdiff-interface.o
    CC http.o
    CC http-walker.o
    CC compat/regex/regex.o
    CC compat/strlcpy.o
    CC compat/memmem.o
    AR libgit.a
    CC xdiff/xdiffi.o
    CC xdiff/xprepare.o
    CC xdiff/xutils.o
    CC xdiff/xemit.o
    CC xdiff/xmerge.o
    AR xdiff/lib.a
    LINK git-fast-import
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: unknown flag: -rpath
collect2: ld returned 1 exit status
make: *** [git-fast-import] Error 1

Error: Unable to upgrade port: 1

Attachments (2)

patch-Makefile.diff (1.3 KB) - added by maccheck@… 13 years ago.
Portfile.diff (404 bytes) - added by maccheck@… 13 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Version: 1.6.01.7.0

comment:2 Changed 13 years ago by maccheck@…

I just realized that -rpath is a new feature in Xcode 3.x. Is there a possibility in MacPorts to check whether I'm compiling on Tiger or Leopard?

Changed 13 years ago by maccheck@…

Attachment: patch-Makefile.diff added

comment:3 Changed 13 years ago by maccheck@…

Could you test the install with new attached Makefile patch, please? I don't have a Tiger machine to test it at the moment...

Changed 13 years ago by maccheck@…

Attachment: Portfile.diff added

comment:4 Changed 13 years ago by garribald@…

I have tested git-core 1.6.0.4 with the new patch and it worked well for me (OS X 10.4.11). Thanks!

comment:5 Changed 13 years ago by ridgcote@…

Attempted to upgrade to git-core 1.6.0.4 from 1.6.0.2, the upgrade failed with the same error as above. Uninstalled git-core 1.6.0.2 and attempted clean install of 1.6.0.4 - also fails, with same error. Recovered 1.6.0.2 from backup for now, running OS X 10.4.11 PPC -Xcode 2.5

comment:6 in reply to:  3 Changed 13 years ago by stolen-from-macports-trac@…

Replying to maccheck@…:

I too have 10.4.11, and the new Makefile patch fixed this problem for me as well.

comment:7 Changed 13 years ago by blb@…

Cc: tobias.weisserth@… added

Cc reporter of dup #17264.

comment:8 Changed 13 years ago by simon@…

Cc: simon@… added
Resolution: fixed
Status: newclosed

I committed the fix in r42257 but didn't increase the revision as Tiger users couldn't install it at all, no need to require updating for everybody.

Simon

comment:9 Changed 13 years ago by ryandesign (Ryan Schmidt)

Thanks! It works for me.

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.