Opened 12 years ago

Closed 11 years ago

#17231 closed defect (fixed)

netcdf install failure

Reported by: mbauer@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: netcdf

Description (last modified by blb@…)

Hello,

I'm trying to install netcdf 4.0 via macports (mac pro, xeon, Tiger) and I get the following error:

subtropics:~/mcms mbauer$ sudo port -v install netcdf         
Password:
--->  Configuring netcdf
configure: netCDF 4.0
checking build system type... i386-apple-darwin8.11.1
checking host system type... i386-apple-darwin8.11.1
checking for a BSD-compatible install... /usr/bin/install
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
configure: checking user options
checking whether CXX is set to ''... no
checking whether FC is set to ''... no
checking whether F90 is set to ''... no
checking whether this is a netCDF-4.x build... yes
configure: Processing NetCDF-4 options.
checking whether netCDF-4 is to be built... 
checking whether DAP client is to be built... 
checking whether new netCDF-4 C++ API is to be built... no
checking whether HDF5 should do data conversions... 
checking whether extra example tests should be run... 
checking whether parallel IO tests should be run... no
checking whether a location for the HDF5 library was specified... .
checking whether a location for the ZLIB library was specified... 
checking whether a location for the SZLIB library was specified... 
checking whether netCDF-4 logging is enabled... 
checking whether netCDF extra tests should be run (developers only)... no
checking whether documentation is to be installed... no
checking whether Fortran compiler(s) should be tested during configure... yes
checking whether configure should try to set compiler flags... yes
checking whether FFIO will be used... no
checking whether to skip C++, F77, or F90 APIs if compiler is broken... yes
checking whether only the C library is desired... no
checking whether examples should be built... yes
checking whether F77 API is desired... yes
checking whether F90 API is desired... yes
checking whether fortran type sizes should be checked... yes
checking whether C API is desired... yes
checking where to get netCDF C-only library for separate fortran libraries... 
checking whether CXX API is desired... yes
checking whether v2 netCDF API should be built... yes
checking whether the ncgen/ncdump should be built... yes
checking whether large file (> 2GB) tests should be run... no
checking whether benchmaks should be run (experimental)... no
checking whether extreme numbers should be used in tests... yes
checking where to put large temp files if large file tests are run... .
checking whether a win32 DLL is desired... no
checking whether separate fortran libs are desired... yes
configure: finding C compiler
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc-4.0 accepts -g... yes
checking for /usr/bin/gcc-4.0 option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of /usr/bin/gcc-4.0... gcc3
checking whether /usr/bin/gcc-4.0 and cc understand -c and -o together... yes
checking for an ANSI C-conforming const... yes
configure: finding Fortran compiler (will not be used if Fortran API is not desired)
checking for xlf90... no
checking for fort... no
checking for xlf95... no
checking for ifort... ifort
checking whether we are using the GNU Fortran compiler... no
checking whether ifort accepts -g... yes
checking for xlf... no
checking for fort... no
checking for xlf95... no
checking for ifort... ifort
checking whether we are using the GNU Fortran 77 compiler... no
checking whether ifort accepts -g... yes
configure: setting up Fortran 90
checking for Fortran flag to compile .f90 files... none
checking fortran 90 modules inclusion flag... -I
checking if Fortran compiler can handle Fortran-90... no
configure: WARNING: No F90 compiler found. F90 API will not be built.
configure: finding C++ compiler (will not be used if C++ API is not desired)
checking whether we are using the GNU C++ compiler... yes
checking whether /usr/bin/g++-4.0 accepts -g... yes
checking dependency style of /usr/bin/g++-4.0... gcc3
configure: setting up libtool
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by /usr/bin/gcc-4.0... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... no
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -p
checking the name lister (/usr/bin/nm -p) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 196608
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... no
checking for /usr/bin/ld option to reload object files... -r
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -p output from /usr/bin/gcc-4.0 object... ok
checking for dsymutil... dsymutil
checking for nmedit... nmedit
checking for -single_module linker flag... yes
checking for -exported_symbols_list linker flag... yes
checking how to run the C preprocessor... /usr/bin/cpp-4.0
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether /usr/bin/g++-4.0 accepts -g... (cached) yes
checking dependency style of /usr/bin/g++-4.0... (cached) gcc3
checking how to run the C++ preprocessor... /usr/bin/g++-4.0 -E
checking whether we are using the GNU Fortran 77 compiler... (cached) no
checking whether ifort accepts -g... (cached) yes
checking whether we are using the GNU Fortran compiler... (cached) no
checking whether ifort accepts -g... (cached) yes
checking for objdir... .libs
checking if /usr/bin/gcc-4.0 supports -fno-rtti -fno-exceptions... no
checking for /usr/bin/gcc-4.0 option to produce PIC... -fno-common -DPIC
checking if /usr/bin/gcc-4.0 PIC flag -fno-common -DPIC works... yes
checking if /usr/bin/gcc-4.0 static flag -static works... no
checking if /usr/bin/gcc-4.0 supports -c -o file.o... yes
checking if /usr/bin/gcc-4.0 supports -c -o file.o... (cached) yes
checking whether the /usr/bin/gcc-4.0 linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin8.11.1 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for ld used by /usr/bin/g++-4.0... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... no
checking whether the /usr/bin/g++-4.0 linker (/usr/bin/ld) supports shared libraries... yes
checking for /usr/bin/g++-4.0 option to produce PIC... -fno-common -DPIC
checking if /usr/bin/g++-4.0 PIC flag -fno-common -DPIC works... yes
checking if /usr/bin/g++-4.0 static flag -static works... no
checking if /usr/bin/g++-4.0 supports -c -o file.o... yes
checking if /usr/bin/g++-4.0 supports -c -o file.o... (cached) yes
checking whether the /usr/bin/g++-4.0 linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin8.11.1 dyld
checking how to hardcode library paths into programs... immediate
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for ifort option to produce PIC... 
checking if ifort static flag  works... no
checking if ifort supports -c -o file.o... yes
checking if ifort supports -c -o file.o... (cached) yes
checking whether the ifort linker (/usr/bin/ld) supports shared libraries... no
checking dynamic linker characteristics... darwin8.11.1 dyld
checking how to hardcode library paths into programs... immediate
checking if libtool supports shared libraries... no
checking whether to build shared libraries... no
checking whether to build static libraries... yes
checking for ifort option to produce PIC... 
checking if ifort static flag  works... no
checking if ifort supports -c -o file.o... yes
checking if ifort supports -c -o file.o... (cached) yes
checking whether the ifort linker (/usr/bin/ld) supports shared libraries... no
checking dynamic linker characteristics... darwin8.11.1 dyld
checking how to hardcode library paths into programs... immediate
configure: finding other utilities
checking for a BSD-compatible install... /usr/bin/install
configure: trying to set fortran flags for this platform
configure: trying to set flags for this platform
checking if _HPUX_SOURCE should be set... no
checking if Solaris -Xa option is needed... CFLAGS=-O2 -fno-common
checking if we need to set _LARGE_FILES despite results of previous tests... _LARGE_FILES=
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
configure: displaying some results
checking CPPFLAGS... -DNDEBUG -Df2cFortran
checking CC CFLAGS... /usr/bin/gcc-4.0 -O2 -fno-common
checking type /usr/bin/gcc-4.0... /usr/bin/gcc-4.0 is /usr/bin/gcc-4.0
checking CXX... /usr/bin/g++-4.0
checking CXXFLAGS... -O2 -fno-common
checking type /usr/bin/g++-4.0... /usr/bin/g++-4.0 is /usr/bin/g++-4.0
checking FC... ifort
checking FFLAGS... -O2
checking type ifort... ifort is /usr/bin/ifort
checking F90... unset
checking AR... ar
checking AR_FLAGS... cru
checking type ar... ar is /usr/bin/ar
checking NM... /usr/bin/nm -p
checking NMFLAGS... 
checking for /usr/bin/nm... /usr/bin/nm -p
checking nm flags... 
checking for C-equivalent to Fortran routine "SUB"... sub_
checking for Fortran "byte"... yes
checking for Fortran "integer*2"... yes
checking if Fortran "byte" is C "signed char"... configure: error: Could not link conftestf.o and conftest.o
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_netcdf/work/netcdf-4.0" && ./configure --prefix=/opt/local --enable-shared " returned error 1
Command output: checking for a BSD-compatible install... /usr/bin/install
configure: trying to set fortran flags for this platform
configure: trying to set flags for this platform
checking if _HPUX_SOURCE should be set... no
checking if Solaris -Xa option is needed... CFLAGS=-O2 -fno-common
checking if we need to set _LARGE_FILES despite results of previous tests... _LARGE_FILES=
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
configure: displaying some results
checking CPPFLAGS... -DNDEBUG -Df2cFortran
checking CC CFLAGS... /usr/bin/gcc-4.0 -O2 -fno-common
checking type /usr/bin/gcc-4.0... /usr/bin/gcc-4.0 is /usr/bin/gcc-4.0
checking CXX... /usr/bin/g++-4.0
checking CXXFLAGS... -O2 -fno-common
checking type /usr/bin/g++-4.0... /usr/bin/g++-4.0 is /usr/bin/g++-4.0
checking FC... ifort
checking FFLAGS... -O2
checking type ifort... ifort is /usr/bin/ifort
checking F90... unset
checking AR... ar
checking AR_FLAGS... cru
checking type ar... ar is /usr/bin/ar
checking NM... /usr/bin/nm -p
checking NMFLAGS... 
checking for /usr/bin/nm... /usr/bin/nm -p
checking nm flags... 
checking for C-equivalent to Fortran routine "SUB"... sub_
checking for Fortran "byte"... yes
checking for Fortran "integer*2"... yes
checking if Fortran "byte" is C "signed char"... configure: error: Could not link conftestf.o and conftest.o

Warning: the following items did not execute (for netcdf): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Going to /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_netcdf/work/netcdf-4.0 and manually trying configure gives the same result.

This can be fixed by issuing FC=g95 export FC and manually launching config and make etc.

Mike

Mike

Change History (7)

comment:1 Changed 12 years ago by blb@…

Description: modified (diff)
Owner: changed from macports-tickets@… to fulton@…
Port: netcdf added

comment:2 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

There is an attempt to fix the problem in r42564.
Could you please tell me if it works.

comment:3 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:4 Changed 12 years ago by blb@…

Owner: changed from fulton@… to macports-tickets@…

netcdf now unmaintained, see r48266.

comment:5 Changed 12 years ago by alakazam@…

NetCDF builds correctly for me, and another user has also confirmed this. I believe this ticket can be closed.

As octave-octcdf depends on netcdf, I'll probably take over maintaining it.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:7 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

netcdf @4.0.1_7 builds fine for me on Leopard (i386) and Snow Leopard (x86_64/i386). Closing due to lack of response.

Note: See TracTickets for help on using tickets.