Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#17340 closed defect (fixed)

wxMaxima 0.7.5 port bugfix

Reported by: usami-k@… Owned by: mf2k (Frank Schima)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port: wxMaxima

Description

I created patch fixed port bug (ticket #16794).

Attachments (2)

Portfile.diff (657 bytes) - added by usami-k@… 12 years ago.
patch-data_Info.plist.in.diff (412 bytes) - added by usami-k@… 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by usami-k@…

Attachment: Portfile.diff added

Changed 12 years ago by usami-k@…

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Port: wxMaxima added

I applied the patches but when i launch wxMaxima a dialog appears and says that "The application sbcl quit unexpectedly". And i when i try to enter text into the input line it says "Not connected to maxima!". But that might be because i don't know how to use Maxima.

comment:2 in reply to:  1 Changed 12 years ago by blb@…

Replying to macsforever2000@…:

I applied the patches but when i launch wxMaxima a dialog appears and says that "The application sbcl quit unexpectedly". And i when i try to enter text into the input line it says "Not connected to maxima!". But that might be because i don't know how to use Maxima.

Works fine here, is your sbcl port current? Can you start sbcl from the command line?

comment:3 Changed 12 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to macsforever2000@…
Status: newassigned

comment:4 Changed 12 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: assignedclosed

I think i found the problem. I had gcc_select set to mp-gcc43. I changed it back to Apple's gcc40 and recompiled sbcl, maxima and wxmaxima and it seems to work now.

Fix applied in r42440.

comment:5 in reply to:  4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Replying to macsforever2000@…:

I think i found the problem. I had gcc_select set to mp-gcc43. I changed it back to Apple's gcc40 and recompiled sbcl, maxima and wxmaxima and it seems to work now.

Ports should not care what you have gcc_selected. Please file tickets against any ports that do care. They need to be updated to use the CC/CXX variables that MacPorts is setting for them.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.