Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#17348 closed defect (fixed)

Aquaterm update broke gnuplot

Reported by: dershow Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: aquaterm gnuplot Cc: pguyot (Paul Guyot), davidm@…, MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: aquaterm

Description

I just did a port update of aquaterm from 1.0.1_0 to 1.0.1_1. I then tried to run gnuplot but got the following error:

dyld: Library not loaded: /opt/local/lib/libaquaterm.1.dylib
  Referenced from: /opt/local/bin/gnuplot
  Reason: image not found
Trace/BPT trap

I figured that aquaterm had just changed the library name or location, so I uninstalled, cleaned, and rebuilt gnuplot. Now gnuplot starts, but aqua is not one of the terminals types that it knows about. So it seems that when building it, it could not find aquaterm.

The new aquaterm contents doesn't include libaquaterm.1.dylib at all.

I am not really sure if this is an aquaterm, or a gnuplot defect, but the recent change that caused it was in aquaterm. My only use for aquaterm at the moment is as a display for gnuplot.

Attachments (1)

Portfile.diff (1.7 KB) - added by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by dershow

I tried to "fool" gnuplot into finding aquaterm, but it didn't work.

This is what I tried:

sudo ln -s /opt/local/Library/Frameworks/AquaTerm.framework/AquaTerm /opt/local/lib/libaquaterm.1.dylib
sudo ln -s /opt/local/Library/Frameworks/AquaTerm.framework/Versions/A/Headers /opt/local/include/aquaterm

Any other suggestions? I am pretty sure that the problem is just that gnuplot builds with aquaterm support if it finds it, but it is no longer searching in the right place since the upgrade to aquaterm.

It seems that this newer version of aquaterm doesn't install the gnuplot adapter that was being used before.

comment:2 Changed 11 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

This should be fixed in r42470, but gnuplot will have to be rebuilt.

We could either increase the gnuplot revision number or update it to the latest version.
See attached file.

Changed 11 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Attachment: Portfile.diff added

comment:3 Changed 11 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:4 Changed 11 years ago by dershow

Thanks. I just synced and updated to aquaterm 1.0.1_2 then rebuilt gnuplot and it works fine.

comment:5 Changed 11 years ago by pguyot (Paul Guyot)

Resolution: fixed
Status: newclosed

So this was fixed in r42470.

comment:6 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.