Opened 12 years ago

Closed 12 years ago

Last modified 7 years ago

#17353 closed defect (worksforme)

attempt to install gnutar seems to depend on gnutar already being installed

Reported by: rssolis@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: ryandesign (Ryan Schmidt), james.sumners@…
Port: gnutar

Description (last modified by mf2k (Frank Schima))

Running MacOS X 10.4.11 on an *old* Powerbook. Attempt to install gnutar seems to fail due to dependency on gnutar already being installed. How do I get around this? See message below:

My-PowerBook:/opt/local/bin$ sudo port install gnutar 
Password:
--->  Extracting gettext
Error: Target org.macports.extract returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gettext/work" && gzip -dc /opt/local/var/macports/distfiles/gettext/gettext-0.17.tar.gz | /usr/bin/gnutar --no-same-owner -xf - " returned error 127
Command output: sh: line 1: /usr/bin/gnutar: No such file or directory

Change History (10)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: gnutar removed
Owner: changed from macports-tickets@… to mww@…
Port: gnutar added

Assigning to maintainer.

comment:2 Changed 12 years ago by mf2k (Frank Schima)

Cc: ryandesign@… added

Cc'ing gettext maintainer.

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

/usr/bin/gnutar is required by MacPorts to extract any port distributed as a tar archive, which is most of them. gnutar is supposed to exist on every Mac; it's provided by Mac OS X. If it's not present on your Mac, something's wrong with the OS. Looking through my receipts, I believe it's provided by BaseSystem.pkg. You could try reinstalling just that pkg from your Mac OS X CD/DVD, or you could archive and install the OS.

comment:4 in reply to:  3 Changed 12 years ago by rssolis@…

Replying to ryandesign@…:

/usr/bin/gnutar is required by MacPorts to extract any port distributed as a tar archive, which is most of them. gnutar is supposed to exist on every Mac; it's provided by Mac OS X. If it's not present on your Mac, something's wrong with the OS. Looking through my receipts, I believe it's provided by BaseSystem.pkg. You could try reinstalling just that pkg from your Mac OS X CD/DVD, or you could archive and install the OS.

Thanks for the info. I reinstalled OS X and /usr/bin/gnutar was there. Additional installs I've attempted with port now seem to be working properly. I appreciate the assistance!

comment:5 Changed 12 years ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:7 Changed 7 years ago by james.sumners@…

I just upgraded from OS 10.8.4 to OS 10.9.0. The gnutar binary (link?) is no longer present (even after installing the command line developer tools with Xcode):

$ ls -l /usr/bin/tar
lrwxr-xr-x  1 root  wheel  6 Oct 23 11:41 /usr/bin/tar -> bsdtar
$ ls -l /usr/bin/gnutar
ls: /usr/bin/gnutar: No such file or directory

Linking bsdtar to gnutar seems to allow a port update outdated to work as expected.

comment:8 in reply to:  7 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: james.sumners@… added

James, this ticket was closed four years ago. Please discuss any new problems you may be having with Mavericks on the macports-users mailing list. Please remove the symlink you created; bsdtar is not gnutar and you should not deceive the system in this way.

comment:9 Changed 7 years ago by james.sumners@…

The bug matched my problem. Do with it as you will. I'm not signing up for a mailing list.

comment:10 Changed 7 years ago by ryandesign (Ryan Schmidt)

I will do nothing further with it, because I cannot reproduce your problem. I believe you may need to read MavericksProblems. If you need further help resolving your issue, please provide further information in a new ticket. This ticket is closed.

Note: See TracTickets for help on using tickets.