Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#17379 closed defect (duplicate)

port uninstall should take variants into account in the dependencies

Reported by: vinc17@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.6.0
Keywords: Cc: mf2k (Frank Schima)
Port:

Description

prunille:~> sudo port -v uninstall aqbanking
--->  Unable to uninstall aqbanking 2.3.3_0, the following ports depend on it:
--->    gnucash
Error: port uninstall failed: Please uninstall the ports that depend on aqbanking first.
prunille:~> port installed gnucash
The following ports are currently installed:
  gnucash @2.2.7_2+without_hbci (active)

but gnucash with the without_hbci variant doesn't depend on aqbanking.

Change History (10)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

I think this is the same underlying problem as #13054.

comment:2 Changed 12 years ago by vinc17@…

I don't think so. #13054 is about an installed port that has an old dependency (this port will not be uninstalled by the upgrade, just deactivated, so that the dependency is still valid in some way, hence the problem). Here, there's no such thing.

comment:3 Changed 12 years ago by jmroot (Joshua Root)

OK, so install must have actually put incorrect entries into the dep_map.

comment:4 Changed 12 years ago by mf2k (Frank Schima)

Cc: macsforever2000@… added

Cc Me!

comment:5 Changed 12 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:6 Changed 12 years ago by jmroot (Joshua Root)

I can't reproduce this. Whether I install gnucash+without_hbci first followed by aqbanking, or do it in the opposite order, port does not complain when I uninstall aqbanking.

If you have steps to reproduce, please give them.

comment:7 Changed 12 years ago by vinc17@…

The bug is still there:

$ port installed gnucash aqbanking
The following ports are currently installed:
  aqbanking @2.3.3_0 (active)
  gnucash @2.2.7_2+without_hbci
  gnucash @2.2.8_0+without_hbci (active)
$ sudo port -v uninstall aqbanking
--->  Unable to uninstall aqbanking 2.3.3_0, the following ports depend on it:
--->    gnucash
Error: port uninstall failed: Please uninstall the ports that depend on aqbanking first.

comment:8 Changed 12 years ago by jmroot (Joshua Root)

Unless you still see this after uninstalling gnucash entirely and then installing with +without_hbci, I still think this is the same as #13054.

comment:9 Changed 12 years ago by tobypeterson

Resolution: duplicate
Status: newclosed

comment:10 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.