Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#17385 closed defect (invalid)

fftw-3 // fftw-3-single fail to install on intel macbook 10.5 mp 10.6 xcode 3.1

Reported by: aptino@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: skymoo (Adam Mercer), tenomoto (Takeshi Enomoto)
Port: fftw-3, fftw-3-single

Description (last modified by skymoo (Adam Mercer))

Macbook4,1 Intel Core2 Duo 2.4Ghz 2GB RAM Mac OS 10.5.5 MacPort 10.6 Xcode 3.1


This error happens to all that require fftw-3 fftw-3-single, like Terminal, xfce and so on.


mymachine$ sudo port install fftw-3
--->  Building fftw-3 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_fftw-3/work/fftw-3.2" && make all " returned error 2
Command output:       _destroy in ct.o
      _mkplan in ct.o
      _destroy in rdft-vrank-geq1.o
      _destroy in rdft-vrank-geq1.o
      _mkplan in rdft-vrank-geq1.o
      _destroy in hc2hc.o
      _destroy in hc2hc.o
      _mkplan in hc2hc.o
      _destroy in vrank-geq1-rdft2.o
      _destroy in vrank-geq1-rdft2.o
      _mkplan in vrank-geq1-rdft2.o
  "_fftw_mkplan_d", referenced from:
      _mkplan in dft-vrank-geq1.o
      _mkplan in ct.o
      _mkplan in ct.o
      _mkplan in rdft-vrank-geq1.o
      _mkplan in hc2hc.o
      _mkplan in hc2hc.o
      _mkplan in vrank-geq1-rdft2.o
  "_fftw_tensor_tornk1", referenced from:
      _mkplan in ct.o
      _mkplan in hc2hc.o
  "_fftw_mkplan_dft", referenced from:
      _mkplan in dft-vrank-geq1.o
      _mkplan in ct.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [libfftw3_threads.la] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Attachments (1)

fftw-3.log (475.8 KB) - added by aptino@… 12 years ago.
log file for fftw-3 installation

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by skymoo (Adam Mercer)

Cc: ram@… takeshi@… added
Description: modified (diff)
Keywords: fftw-3 removed
Port: fftw-3-single added
Priority: HighNormal

Can you attach the full debug output, as I can't reproduce this under Intel Mac OS X 10.5.5, Xcode 3.1.1

$ sudo port clean fftw-3
$ sudo port -d build fftw-3 > fftw-3.log

Changed 12 years ago by aptino@…

Attachment: fftw-3.log added

log file for fftw-3 installation

comment:2 in reply to:  1 Changed 12 years ago by aptino@…

Replying to ram@…:

Can you attach the full debug output, as I can't reproduce this under Intel Mac OS X 10.5.5, Xcode 3.1.1

$ sudo port clean fftw-3
$ sudo port -d build fftw-3 > fftw-3.log

see attached file...

comment:3 Changed 12 years ago by skymoo (Adam Mercer)

I can't find the error you previously reported in the log, what happens when you try to install?

comment:4 in reply to:  3 Changed 12 years ago by aptino@…

Replying to ram@…:

I can't find the error you previously reported in the log, what happens when you try to install?

Huh, well now it installs just fine.. weird.

well, dunno what went wrong, but as you can see I DID have problems.. maybe cleaning the build was what it needed..

thanks:)

comment:5 Changed 12 years ago by skymoo (Adam Mercer)

Resolution: invalid
Status: newclosed

I've seen similar transient failures, best thing to do if a port fails is to clean and try again. Glad its working now, as I had no clue where to start debugging that.

comment:6 in reply to:  5 Changed 12 years ago by aptino@…

Replying to ram@…:

I've seen similar transient failures, best thing to do if a port fails is to clean and try again. Glad its working now, as I had no clue where to start debugging that.

Yes it seems like that's the case here. Thank you so much for your help, I was really stunned how short time it took from I reported the ticket to you responded:)

comment:7 Changed 12 years ago by jmroot (Joshua Root)

Sounds like it was the Tcl env bug.

comment:8 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.