Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#17388 closed defect (duplicate)

poppler 0.10.1 build failure on PPC

Reported by: Liontooth (David Liontooth) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: FTBFS Cc:
Port: poppler

Description

Build failed on OSX 10.4.11 PPC with cairo 1.4.10_0:

g++ --version powerpc-apple-darwin8-g++-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5367)

Making all in test /usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I.. -I../poppler -I.. -I../poppler -I../glib -I../glib -I/opt/local/include -I/opt/local/include -Wall -Wno-write-strings -O2 -MT perf-test.o -MD -MP -MF .deps/perf-test.Tpo -c -o perf-test.o perf-test.cc mv -f .deps/perf-test.Tpo .deps/perf-test.Po /usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I.. -I../poppler -I.. -I../poppler -I../glib -I../glib -I/opt/local/include -I/opt/local/include -Wall -Wno-write-strings -O2 -MT perf-test-preview-dummy.o -MD -MP -MF .deps/perf-test-preview-dummy.Tpo -c -o perf-test-preview-dummy.o perf-test-preview-dummy.cc mv -f .deps/perf-test-preview-dummy.Tpo .deps/perf-test-preview-dummy.Po /bin/sh ../libtool --tag=CXX --mode=link /usr/bin/g++-4.0 -Wall -Wno-write-strings -O2 -L/opt/local/lib -o perf-test perf-test.o perf-test-preview-dummy.o ../poppler/libpoppler.la -L/opt/local/lib -lfreetype -lz -lz mkdir .libs /usr/bin/g++-4.0 -Wall -Wno-write-strings -O2 -o .libs/perf-test perf-test.o perf-test-preview-dummy.o -Wl,-bind_at_load -L/opt/local/lib ../poppler/.libs/libpoppler.dylib /opt/local/lib/libjpeg.dylib -lopenjpeg /opt/local/lib/libxml2.dylib -lpthread /opt/local/lib/libiconv.dylib -lm /opt/local/lib/libfontconfig.dylib /opt/local/lib/libexpat.dylib /opt/local/lib/libfreetype.dylib -lz /usr/bin/ld: Undefined symbols: fnmatch(char const*, char const*, int) collect2: ld returned 1 exit status make[2]: * [perf-test] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

It looks like it's just the test suite that fails?

The build with cairo-1.8.4 similarly fails:

/usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I.. -I../poppler -I.. -I../poppler -I../glib -I../glib -DXTHREADS -I/opt/local/include/cairo -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include/libpng12 -I/usr/X11R6/include -I/opt/local/include/freetype2 -I/opt/local/include -DXTHREADS -D_REENTRANT -I/opt/local/include/gtk-2.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/atk-1.0 -I/opt/local/include/cairo -I/opt/local/include/pango-1.0 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include/libpng12 -I/usr/X11R6/include -I/opt/local/include/libglade-2.0 -I/opt/local/include/libxml2 -I/opt/local/include -I/opt/local/include -Wall -Wno-write-strings -O2 -MT perf-test-preview-dummy.o -MD -MP -MF .deps/perf-test-preview-dummy.Tpo -c -o perf-test-preview-dummy.o perf-test-preview-dummy.cc mv -f .deps/perf-test-preview-dummy.Tpo .deps/perf-test-preview-dummy.Po /bin/sh ../libtool --tag=CXX --mode=link /usr/bin/g++-4.0 -Wall -Wno-write-strings -O2 -L/opt/local/lib -o perf-test perf-test.o perf-test-preview-dummy.o ../poppler/libpoppler.la -L/opt/local/lib -lfreetype -lz -lz /usr/bin/g++-4.0 -Wall -Wno-write-strings -O2 -o .libs/perf-test perf-test.o perf-test-preview-dummy.o -Wl,-bind_at_load -L/opt/local/lib ../poppler/.libs/libpoppler.dylib /opt/local/lib/libjpeg.dylib -lopenjpeg /opt/local/lib/libxml2.dylib -lpthread /opt/local/lib/libiconv.dylib -lm /opt/local/lib/libfontconfig.dylib /opt/local/lib/libexpat.dylib /opt/local/lib/libfreetype.dylib -lz /usr/bin/ld: Undefined symbols: fnmatch(char const*, char const*, int) collect2: ld returned 1 exit status make[2]: * [perf-test] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

poppler builds fine on Intel; thanks for packaging!

Change History (2)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #17389.

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.