Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#17392 closed enhancement (fixed)

RFE: add a few more plugin and bindings to graphviz

Reported by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port: graphviz, graphviz-devel

Description

Attached is a proposed increase in the number of plugins and bindings of graphviz.

Attachments (1)

Portfile.diff (5.5 KB) - added by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) 12 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by ryandesign (Ryan Schmidt)

My understanding was that --with-quartz only worked on Leopard and above.

I tried --with-ming yesterday; it didn't seem to do anything (-Tswf was still not available).

The python bindings had problems building last time I tried. I can try again.

Part of this could be a duplicate of #11225.

#15024 may also still be relevant.

comment:2 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Attached is my second attempt.

--with-quartz is only enabled on Leopard or above.

I think I may have finally gotten the python installations right.
Only the .py files are installed.
Graphviz does not feel the need to install .pyc or .pyo files.
I tried a compileall command, but the .py file is a link, which makes the workaround a pain in the neck.

I can not get the ocaml variant to work.

I do not have a -Tswf example that works, but the configure script says if successfully found ming.

Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Attachment: Portfile.diff added

comment:3 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

May I go ahead and commit this patch?

comment:4 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed

Fixed in r45084 (maintainer timeout).

comment:5 Changed 12 years ago by ryandesign (Ryan Schmidt)

Port: graphviz-devel added

Fixed whitespace in r45153. Merged r45084 and r45153 to graphviz-devel in r45155.

comment:6 Changed 12 years ago by (none)

Milestone: Port Enhancements

Milestone Port Enhancements deleted

Note: See TracTickets for help on using tickets.