Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#17530 closed defect (fixed)

glib2 should depend on perl and python

Reported by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port: glib2

Description

glib2 installs glib-mkenums and gtester-report into ${prefix}/bin, which are
perl and python scripts respectively.
Attached is a proposed change to ensure that glib2 uses MacPorts perl and python.

Attachments (1)

Portfile.diff (930 bytes) - added by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

May I go ahead and commit this pacth?

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Take out the change to master_sites, it has no place in this patch.

Changed 10 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Attachment: Portfile.diff added

comment:3 Changed 10 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed

Fixes in r45190 (maintainer timeout).

comment:4 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

r45190 didn't actually make those python scripts use MacPorts python, and the python parts of that revision were reverted in r78594. I fixed it to use a compatible python version in r87671.

Note: See TracTickets for help on using tickets.