Opened 12 years ago

Closed 11 years ago

#17683 closed defect (duplicate)

Crash when building glade (gtk)

Reported by: allen@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: gtk2

Description (last modified by blb@…)

Guys, I apologize in advance, if this is not a bug... If I am doing something wrong, let me know.

Note, I have run this before, failed at this point, so it picks up at gtk2 build... I have just upgraded and synced port.

xxxxx-xxxxxx-macbook-pro:~ xxxxxxxxxxx$ sudo port install glade
Password:
--->  Building gtk2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_gtk2/work/gtk+-2.14.5" && make all " returned error 2
Command output: make  all-recursive
Making all in po
make[2]: Nothing to be done for `all'.
Making all in po-properties
make[2]: Nothing to be done for `all'.
Making all in gdk-pixbuf
make  all-recursive
Making all in pixops
make[4]: Nothing to be done for `all'.
Making all in gdk
make  all-recursive
Making all in x11
make[4]: Nothing to be done for `all'.
Making all in .
/bin/sh ../libtool --mode=link /usr/bin/gcc-4.0  -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -funroll-loops -fstrict-aliasing -Wall  -L/opt/local/lib -o libgdk-x11-2.0.la  -version-info 1400:5:1400 -export-dynamic -rpath /opt/local/lib  -export-symbols-regex "^[^_].*"  gdk.lo gdkapplaunchcontext.lo gdkcairo.lo gdkcolor.lo gdkcursor.lo gdkdisplay.lo gdkdisplaymanager.lo gdkdnd.lo gdkdraw.lo gdkevents.lo gdkfont.lo gdkgc.lo gdkglobals.lo gdkimage.lo gdkkeys.lo gdkkeyuni.lo gdkpango.lo gdkpixbuf-drawable.lo gdkpixbuf-render.lo gdkpixmap.lo gdkpolyreg-generic.lo gdkrectangle.lo gdkregion-generic.lo gdkrgb.lo gdkscreen.lo gdkselection.lo gdkvisual.lo gdkwindow.lo gdkwindowimpl.lo gdkenumtypes.lo x11/libgdk-x11.la -L/opt/local/lib -L/usr/X11/lib -lpangocairo-1.0 -lcairo -lpangoft2-1.0 -lpixman-1 -lpng12 -lpango-1.0 -lm -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv -lfontconfig -lexpat -lfreetype -lz -lXinerama -lXi -lXrandr -lXcursor -lXrender -lXcomposite -lXext -lXdamage -lXfixes -lX11 -lXau -lXdmcp    -ltiff -ljpeg -L/opt/local/lib -lpng12 -lz   -ljasper -lm  ../gdk-pixbuf/libgdk_pixbuf-2.0.la 
libtool: link: rm -fr  .libs/libgdk-x11-2.0.exp .libs/libgdk-x11-2.0.lax
libtool: link: /usr/bin/nm -p  .libs/gdk.o .libs/gdkapplaunchcontext.o .libs/gdkcairo.o .libs/gdkcolor.o .libs/gdkcursor.o .libs/gdkdisplay.o .libs/gdkdisplaymanager.o .libs/gdkdnd.o .libs/gdkdraw.o .libs/gdkevents.o .libs/gdkfont.o .libs/gdkgc.o .libs/gdkglobals.o .libs/gdkimage.o .libs/gdkkeys.o .libs/gdkkeyuni.o .libs/gdkpango.o .libs/gdkpixbuf-drawable.o .libs/gdkpixbuf-render.o .libs/gdkpixmap.o .libs/gdkpolyreg-generic.o .libs/gdkrectangle.o .libs/gdkregion-generic.o .libs/gdkrgb.o .libs/gdkscreen.o .libs/gdkselection.o .libs/gdkvisual.o .libs/gdkwindow.o .libs/gdkwindowimpl.o .libs/gdkenumtypes.o   x11/.libs/libgdk-x11.a | sed -n -e 's/^.*[	 ]\([BCDEGRST][BCDEGRST]*\)[	 ][	 ]*_\([_A-Za-z][_A-Za-z0-9]*\)$/\1 _\2 \2/p' | /usr/bin/sed 's/.* //' | sort | uniq > .libs/libgdk-x11-2.0.exp
libtool: link: /usr/bin/grep -E -e "^[^_].*" ".libs/libgdk-x11-2.0.exp" > ".libs/libgdk-x11-2.0.expT"
libtool: link: mv -f ".libs/libgdk-x11-2.0.expT" ".libs/libgdk-x11-2.0.exp"
libtool: link: (cd .libs/libgdk-x11-2.0.lax/libgdk-x11.a && ar x "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_gtk2/work/gtk+-2.14.5/gdk/x11/.libs/libgdk-x11.a")
libtool: link: sed 's,^,_,' < .libs/libgdk-x11-2.0.exp > .libs/libgdk-x11-2.0-symbols.expsym
libtool: link: /usr/bin/gcc-4.0 -dynamiclib -Wl,-undefined -Wl,dynamic_lookup -o .libs/libgdk-x11-2.0.0.dylib  .libs/gdk.o .libs/gdkapplaunchcontext.o .libs/gdkcairo.o .libs/gdkcolor.o .libs/gdkcursor.o .libs/gdkdisplay.o .libs/gdkdisplaymanager.o .libs/gdkdnd.o .libs/gdkdraw.o .libs/gdkevents.o .libs/gdkfont.o .libs/gdkgc.o .libs/gdkglobals.o .libs/gdkimage.o .libs/gdkkeys.o .libs/gdkkeyuni.o .libs/gdkpango.o .libs/gdkpixbuf-drawable.o .libs/gdkpixbuf-render.o .libs/gdkpixmap.o .libs/gdkpolyreg-generic.o .libs/gdkrectangle.o .libs/gdkregion-generic.o .libs/gdkrgb.o .libs/gdkscreen.o .libs/gdkselection.o .libs/gdkvisual.o .libs/gdkwindow.o .libs/gdkwindowimpl.o .libs/gdkenumtypes.o   .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkapplaunchcontext-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkasync.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkcolor-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkcursor-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkdisplay-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkdnd-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkdrawable-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkevents-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkfont-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkgc-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkgeometry-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkglobals-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkim-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkimage-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkinput-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkinput-xfree.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkinput.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkkeys-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkmain-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkpixmap-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkproperty-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkscreen-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkselection-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkspawn-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdktestutils-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkvisual-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkwindow-x11.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkxftdefaults.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/gdkxid.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/xsettings-client.o .libs/libgdk-x11-2.0.lax/libgdk-x11.a/xsettings-common.o   -L/opt/local/lib -L/usr/X11/lib /opt/local/lib/libpangocairo-1.0.dylib /opt/local/lib/libcairo.dylib /opt/local/lib/libpangoft2-1.0.dylib /opt/local/lib/libpixman-1.dylib /opt/local/lib/libpango-1.0.dylib /opt/local/lib/libfontconfig.dylib /opt/local/lib/libexpat.dylib /opt/local/lib/libfreetype.dylib /usr/X11/lib/libXinerama.1.0.0.dylib /usr/X11/lib/libXi.6.0.0.dylib /usr/X11/lib/libXrandr.2.1.0.dylib /usr/X11/lib/libXcursor.1.0.2.dylib /usr/X11/lib/libXrender.1.3.0.dylib /opt/local/lib/libXrender.dylib /usr/X11/lib/libXcomposite.1.0.0.dylib /usr/X11/lib/libXext.6.4.0.dylib /usr/X11/lib/libXdamage.1.1.0.dylib /usr/X11/lib/libXfixes.3.1.0.dylib /usr/X11/lib/libX11.6.2.0.dylib /usr/X11/lib/libXau.6.0.0.dylib /usr/X11/lib/libXdmcp.6.0.0.dylib ../gdk-pixbuf/.libs/libgdk_pixbuf-2.0.dylib /opt/local/lib/libgio-2.0.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgmodule-2.0.dylib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib /opt/local/lib/libiconv.dylib /opt/local/lib/libtiff.dylib -lc /opt/local/lib/libpng12.dylib -lz /opt/local/lib/libjasper.dylib /opt/local/lib/libjpeg.dylib -lm    -framework Carbon -install_name  /opt/local/lib/libgdk-x11-2.0.0.dylib -compatibility_version 1401 -current_version 1401.5 -Wl,-single_module -Wl,-exported_symbols_list,.libs/libgdk-x11-2.0-symbols.expsym
i686-apple-darwin9-gcc-4.0.1: /usr/X11/lib/libXdamage.1.1.0.dylib: No such file or directory
make[4]: *** [libgdk-x11-2.0.la] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: The following dependencies failed to build: gconf gtk2 orbit2 libidl libbonoboui gnome-vfs desktop-file-utils popt gnome-mime-data libbonobo libglade2 libgnome libgnomecanvas libart_lgpl libgail-gnome at-spi gnome-panel evolution-data-server db46 gnome-keyring libgcrypt libgpg-error libtasn1 gnome-platform-suite gnome-vfs-monikers libgnomeui gnome-icon-theme hicolor-icon-theme icon-naming-utils p5-xml-simple p5-xml-namespacesupport p5-xml-sax libsoup gnutls lzo opencdk readline nspr nss sqlite3 gnome-desktop gnome-themes gtk-engines2 py25-gnome py25-gtk py25-cairo py25-numpy fftw-3 py25-nose py25-setuptools py25-zlib py25-gobject py25-orbit startup-notification gnome-menus libgweather librsvg libcroco libgsf bzip2 libwnck
Error: Status 1 encountered during processing.

Change History (9)

comment:1 Changed 12 years ago by blb@…

Description: modified (diff)
Port: gtk2 added

comment:2 Changed 12 years ago by blb@…

I believe the recommended fix for this is to upgrde to the latest Xquartz.

comment:3 Changed 12 years ago by dbevans (David B. Evans)

Also you should consider building glade3 as that is the current stable version. port glade is the older version 2 which is no longer being developed. Its there for historical reasons mainly.

comment:4 in reply to:  2 ; Changed 12 years ago by allen@…

Replying to blb@…:

I believe the recommended fix for this is to upgrde to the latest Xquartz.

seems to be working after upgrading xquartz... how the heck was I supposed to know that... shouldn't the requirements in the port check for xquartz version before attempting to build gtk2?

Thanks guys.

comment:5 in reply to:  4 Changed 12 years ago by allen@…

Replying to allen@…:

Replying to blb@…:

I believe the recommended fix for this is to upgrde to the latest Xquartz.

seems to be working after upgrading xquartz... how the heck was I supposed to know that... shouldn't the requirements in the port check for xquartz version before attempting to build gtk2?

Thanks guys.

It installed without further error...but won't run. I tried to reinstall, it says the port is active...but won't run. Anyone have any ideas? Here is what I get:

allen-xxxxx-macbook-pro:~ allenxxxxx$ sudo port install glade3 Password: Skipping org.macports.activate (glade3 ) since this port is already active ---> Cleaning glade3 allen-xxxxx-macbook-pro:~ allenxxxxx$ glade3 -bash: glade3: command not found allen-xxxxx-macbook-pro:~ allenxxxxxx$ glade-3 -bash: glade-3: command not found allen-xxxxx-macbook-pro:~ allenxxxxx$ glade -bash: glade: command not found allen-xxxxx-macbook-pro:~ allenxxxxx$

comment:6 Changed 12 years ago by blb@…

I don't have glade3 installed so I'm not sure what the binary is, but you can use port contents glade3 to see what files it installed, maybe in that list will be the answer to what you run.

comment:7 in reply to:  6 Changed 12 years ago by allen@…

Replying to blb@…:

I don't have glade3 installed so I'm not sure what the binary is, but you can use port contents glade3 to see what files it installed, maybe in that list will be the answer to what you run.

Thanks, that worked. This ticket can be closed, but I would recommend that xquartz be added to port requirements list first. Thanks for everything.

comment:8 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:9 Changed 11 years ago by nox@…

Resolution: duplicate
Status: newclosed

Seems to be a duplicate of #17356

Note: See TracTickets for help on using tickets.