Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#17903 closed defect (fixed)

exo: universal compilation failure... missing mmintrin.h

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: afb@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: compilation universal Cc: afb@…, MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: exo

Description

builds fine -universal

 /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I.. -DDATADIR=\"/opt/local/share\" -DEXO_COMPILATION -DG_LOG_DOMAIN=\"exo\" -DLIBEXECDIR=\"/opt/local/libexec\" -DLIBEXO_VERSION_API=\"0.3\" -DPACKAGE_LOCALE_DIR=\"/opt/local/share/locale\" -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.Internal.sdk -I/opt/local/include/gtk-2.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/atk-1.0 -I/opt/local/include/cairo -I/opt/local/include/pango-1.0 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include/libpng12 -I/opt/local/include/xfce4 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -O2 -isysroot /Developer/SDKs/MacOSX10.5.Internal.sdk -arch ppc -arch i386 -mmacosx-version-min=10.5 -DNDEBUG -DG_DISABLE_CAST_CHECKS -c exo-gdk-pixbuf-extensions.c  -fno-common -DPIC -o .libs/libexo_0_3_la-exo-gdk-pixbuf-extensions.o
exo-gdk-pixbuf-extensions.c:47:22: error: mmintrin.h: No such file or directory
lipo: can't figure out the architecture type of: /var/tmp//ccwBinHS.out
make[3]: *** [libexo_0_3_la-exo-gdk-pixbuf-extensions.lo] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

The problem is that mmintrin.h is available for i386 but not ppc:

~ $ /usr/bin/gcc-4.0 -c -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch i386 -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk conftest.c

~ $ /usr/bin/gcc-4.0 -c -O2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch ppc -mmacosx-version-min=10.5 -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk conftest.c
conftest.c:63:22: error: mmintrin.h: No such file or directory

It looks like this port will need some split build / lipo magic like in cairo...

Attachments (1)

exo-mmintrin.diff (376 bytes) - added by afb@… 12 years ago.
exo-mmintrin.diff

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

Changed 12 years ago by afb@…

Attachment: exo-mmintrin.diff added

exo-mmintrin.diff

comment:2 Changed 12 years ago by afb@…

Status: newassigned

Or just use the same versioning on the header file that is already used on the actual code ?

comment:4 Changed 12 years ago by afb@…

Resolution: fixed
Status: assignedclosed

Fixed, r46067.

comment:5 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.