Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#18166 closed defect (worksforme)

texlive_base fails to install

Reported by: andilipa@… Owned by: milosh@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: jjstickel@…, tmdias@…, mennucc1@…, ryandesign (Ryan Schmidt), jpineda@…, neric27@…, jeremyhu (Jeremy Huddleston Sequoia), alakazam@…, McDutchie (Martijn Dekker)
Port: texlive_base xorg-libs

Description (last modified by milosh@…)

Hello,

Over the past 6+ days I have tried upgrading asymptote/tex without any success. Two weeks ago I had no problems installing asymptote 1.56 and texlive. But then both texlive and asymptote were upgraded, and my attempts to upgrade to the current version fail for texlive_base.

I have attached a file with the error message. I am working on Mac OS X 10.4.11.

Any help will be appreciated.

Best, Dilip

Attachments (4)

error (4.6 KB) - added by andilipa@… 11 years ago.
text file with the error message
Portfile_texlive_base.diff (834 bytes) - added by jjstickel@… 11 years ago.
patch-texk_xdvik_configure.diff (978 bytes) - added by jjstickel@… 11 years ago.
patch-ffmpegdevel-1.diff (668 bytes) - added by jm@… 11 years ago.

Download all attachments as: .zip

Change History (34)

Changed 11 years ago by andilipa@…

Attachment: error added

text file with the error message

comment:1 Changed 11 years ago by jjstickel@…

I am also experiencing this problem on Mac OS X 10.4.11. I don't know if it is relevant, but I recently switched to using the macport x11 libs.

comment:2 Changed 11 years ago by jjstickel@…

Cc: jjstickel@… added

Cc Me!

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to milosh@…

comment:4 Changed 11 years ago by milosh@…

Owner: changed from milosh@… to jeremyhu@…
Port: xorg-libs added

comment:5 Changed 11 years ago by jjstickel@…

After some searching, I think this is NOT related to X11 libraries. Those are just warnings. The error is "multiple definitions of symbol _hash_create" in libkpathsea.a and libc.dylib. This thread seems relevant:

http://www.tug.org/pipermail/tex-live/2006-December/011599.html

If I follow correctly, the -lc needs to be after libkpathsea.la in the link line, as the -lm currently is. I don't know how to make it do that...

comment:6 in reply to:  5 ; Changed 11 years ago by andilipa@…

Replying to jjstickel@…:

After some searching, I think this is NOT related to X11 libraries. Those are just warnings. The error is "multiple definitions of symbol _hash_create" in libkpathsea.a and libc.dylib. This thread seems relevant:

http://www.tug.org/pipermail/tex-live/2006-December/011599.html

If I follow correctly, the -lc needs to be after libkpathsea.la in the link line, as the -lm currently is. I don't know how to make it do that...

I don't know enough to say what is going on, but R also fails to build/install. It fails at the point of installing glib2. The final error is that glib2, jpeg, pango, and tiff failed to build. It is odd that only two weeks ago, this installed without any hitch.

comment:7 Changed 11 years ago by tmdias@…

Cc: tmdias@… added

Cc Me!

comment:8 Changed 11 years ago by mennucc1@…

Cc: mennucc1@… added

Cc Me!

comment:9 in reply to:  6 Changed 11 years ago by jjstickel@…

Replying to andilipa@…:

I don't know enough to say what is going on, but R also fails to build/install. It fails at the point of installing glib2. The final error is that glib2, jpeg, pango, and tiff failed to build. It is odd that only two weeks ago, this installed without any hitch.

This is not likely related. Please report this separately on the mailing list or as a separate ticket if you are sure it is an unreported bug.

Changed 11 years ago by jjstickel@…

Attachment: Portfile_texlive_base.diff added

Changed 11 years ago by jjstickel@…

comment:10 Changed 11 years ago by jjstickel@…

The attached additional patch to the xdvik configure file and the attached patch to the Portfile worked for me. This is just a hack that I figured out. This bug should probably be reported upstream so that the tex developers can fix it correctly.

comment:11 Changed 11 years ago by andilipa@…

Thank you very much! The fix you suggest works out.

comment:12 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

comment:13 Changed 11 years ago by jpineda@…

Cc: jpineda@… added

Cc Me!

comment:14 Changed 11 years ago by neric27@…

Cc: neric27@… added

Cc Me!

comment:15 in reply to:  10 Changed 11 years ago by ryandesign (Ryan Schmidt)

Owner: changed from jeremyhu@… to milosh@…

Replying to jjstickel@…:

The attached additional patch to the xdvik configure file and the attached patch to the Portfile worked for me. This is just a hack that I figured out. This bug should probably be reported upstream so that the tex developers can fix it correctly.

Thanks, this works for me. I applied your changes in r46244, except I did not add the line "use_parallel_build no" because that's not relevant to this ticket. I filed it as #18303.

I'm leaving the ticket open and assigned to texlive_base's maintainer so that he can inform the upstream developers.

comment:16 Changed 11 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Cc: jeremyhu@… added

Cc Me!

comment:17 Changed 11 years ago by jm@…

After sync, still does not build. As a result, dirac does not build. And it breaks FFmpeg compilation. I would appreciate that you deactivate libdirac in ffmpeg-devel until the dust comes down. Attached is a patch.

Changed 11 years ago by jm@…

Attachment: patch-ffmpegdevel-1.diff added

comment:18 Changed 11 years ago by jm@…

/bin/sh ../libtool --mode=link /usr/bin/gcc-4.0 -o xdvi-xaw.bin -L/opt/local/lib browser.o dvi-draw.o dvi-init.o dvisel.o encodings.o events.o filehist.o font-open.o gf.o hypertex.o image-magick.o mime.o my-snprintf.o my-vsnprintf.o pagehist.o pk.o print-internal.o psdps.o psgs.o psheader.o psnews.o read-mapfile.o search-internal.o special.o string-utils.o tfmload.o util.o vf.o xdvi.o xserver-info.o x_util.o ./gui/libgui.a ../../libs/t1lib/libt1.a ../../libs/t1lib/../type1/libtype1.a -L/usr/X11R6/lib -lXaw -lXmu -lXt -lSM -lICE -lXp -lXext -lXpm -lX11 -liconv ../kpathsea/libkpathsea.la -lm /usr/bin/gcc-4.0 -o xdvi-xaw.bin browser.o dvi-draw.o dvi-init.o dvisel.o encodings.o events.o filehist.o font-open.o gf.o hypertex.o image-magick.o mime.o my-snprintf.o my-vsnprintf.o pagehist.o pk.o print-internal.o psdps.o psgs.o psheader.o psnews.o read-mapfile.o search-internal.o special.o string-utils.o tfmload.o util.o vf.o xdvi.o xserver-info.o x_util.o -L/opt/local/lib ./gui/libgui.a ../../libs/t1lib/libt1.a ../../libs/t1lib/../type1/libtype1.a -L/usr/X11R6/lib -lXaw -lXmu -lXt -lSM -lICE -lXp -lXext -lXpm -lintl -lc -lX11 -lXau -lXdmcp -liconv ../kpathsea/.libs/libkpathsea.a -lm /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _XtRemoveTimeOut events.o definition of _XtRemoveTimeOut in section (TEXT,text) /opt/local/lib/libXt.dylib(NextEvent.o) definition of _XtRemoveTimeOut /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _XtAddTimeOut events.o definition of _XtAddTimeOut in section (TEXT,text) /opt/local/lib/libXt.dylib(NextEvent.o) definition of _XtAddTimeOut /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _XtAppAddTimeOut events.o definition of _XtAppAddTimeOut in section (TEXT,text) /opt/local/lib/libXt.dylib(NextEvent.o) definition of _XtAppAddTimeOut /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: multiple definitions of symbol _hash_create /usr/lib/gcc/i686-apple-darwin8/4.0.1/../../../libc.dylib(strhash.So) definition of _hash_create ../kpathsea/.libs/libkpathsea.a(hash.o) definition of _hash_create in section (TEXT,text) /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _vendorShellWidgetClass /opt/local/lib/libXaw.dylib(single module) definition of _vendorShellWidgetClass /opt/local/lib/libXt.dylib(Vendor.o) definition of _vendorShellWidgetClass /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _vendorShellClassRec /opt/local/lib/libXaw.dylib(single module) definition of _vendorShellClassRec /opt/local/lib/libXt.dylib(Vendor.o) definition of _vendorShellClassRec collect2: ld returned 1 exit status make[2]: * [xdvi-xaw.bin] Error 1 make[1]: * [all] Error 1 make: * [all] Error 1

Warning: the following items did not execute (for texlive_base): org.macports.activate org.macports.build org.macports.destroot org.macports.install Error: Status 1 encountered during processing.

comment:19 Changed 11 years ago by jm@…

Sorry, sudo port -v clean solved this issue.

comment:20 Changed 11 years ago by alakazam@…

Cc: alakazam@… added

Cc Me!

comment:21 Changed 11 years ago by ozak@…

Cc: ozak@… added

Cc Me!

comment:22 Changed 11 years ago by McDutchie (Martijn Dekker)

Problem confirmed on Panther (10.3.9) as well as Tiger (10.4.11). As described above on both OSs.

comment:23 Changed 11 years ago by McDutchie (Martijn Dekker)

Cc: martijn@… added

Cc Me!

comment:24 Changed 11 years ago by milosh@…

Description: modified (diff)

comment:25 in reply to:  5 Changed 11 years ago by matt.r.walker@…

Replying to jjstickel@…:

After some searching, I think this is NOT related to X11 libraries. Those are just warnings. The error is "multiple definitions of symbol _hash_create" in libkpathsea.a and libc.dylib. This thread seems relevant:

http://www.tug.org/pipermail/tex-live/2006-December/011599.html

If I follow correctly, the -lc needs to be after libkpathsea.la in the link line, as the -lm currently is. I don't know how to make it do that...

Despite seeing the modification to the port file and patch to xdivk provided above in my local source, I still receive the reported error under Tiger (10.4.11). jjstickel@… was right when he said that -lc needs to come after libkpathsea.a. I manually executed:

sudo /usr/bin/gcc-4.0 -o xdvi-xaw.bin browser.o dvi-draw.o dvi-init.o dvisel.o encodings.o events.o filehist.o font-open.o gf.o hypertex.o image-magick.o mime.o my-snprintf.o my-vsnprintf.o pagehist.o pk.o print-internal.o psdps.o psgs.o psheader.o psnews.o read-mapfile.o search-internal.o special.o string-utils.o tfmload.o util.o vf.o xdvi.o xserver-info.o x_util.o -L/opt/local/lib ./gui/libgui.a ../../libs/t1lib/libt1.a ../../libs/t1lib/../type1/libtype1.a -L/usr/X11R6/lib -lXaw -lXmu -lXt -lSM -lICE -lXp -lXext -lXpm -lX11 -lXau -lXdmcp -lintl -liconv ../kpathsea/.libs/libkpathsea.a -lc -lm

(which is the same as the broken build command except moving -lc) in the:

/opt/local/var/macports/sources/rsync.macports.org/release/ports/print/teTeX/work/tetex-src-3.0/texk/xdvik

directory, which successfully built xdvi-xaw.bin. Afterward, the rest of the build went without error using the standard upgrade command. I'm not savvy enough to trace down what exactly needs to be changed in the make files as they seem to be multiply nested, but this is at least a work around.

comment:26 Changed 11 years ago by ozak@…

I also have Tiger 10.4.11 but the provided diff files actually solved the problem in my case.

comment:27 Changed 11 years ago by ozak@…

Cc: ozak@… removed

Cc Me!

comment:28 Changed 11 years ago by mennucc1@…

For the record, yesterday I cleaned all of texlive, and 'install texlive', and it worked

comment:29 Changed 11 years ago by milosh@…

Resolution: worksforme
Status: newclosed

comment:30 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.