Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#18235 closed defect (wontfix)

screen-4.0.3_3+darwin_9 Screen breaks OSX CLI tools.

Reported by: lhunath@… Owned by: digdog@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: cpettitt@…, khalsah@…, dan@…, noah.easterly@…, lhunath@…, jeremyhu (Jeremy Huddleston Sequoia), macports@…, joel.chippindale@…, gdelfino@…, rtlechow@…, macports@…
Port: screen

Description

When I upgraded from 4.0.3_1 to 4.0.3_3+darwin_9, certain OS X tools suddenly stopped working.

Examples are: pbcopy, pbpaste: Completely dead, no error messages, exit code 1. hdiutil attach: Doesn't contact the OS X keychain anymore for encrypted images.

Moreover, I noticed that 4.0.3_1 understood the deflogin and login screen commands (they are in my .screenrc) while 4.0.3_3 now complains about those. Also, my environment (set by .profile) is not kept when opening screens inside screen; so commands in .bashrc that depend on it, like PATH being set, started failing. I've had to add shell "-bash" to .screenrc to fix that, because it doesn't understand deflogin anymore.

For now; I'm staying on 4.0.3_1 until these issues are fixed.

Screen should understand deflogin and login, they are included in man screen.

Change History (26)

comment:1 Changed 8 years ago by lhunath@…

  • Cc lhunath@… added

Cc Me!

comment:2 Changed 8 years ago by macsforever2000@…

  • Cc lhunath@… removed
  • Keywords screen removed
  • Owner changed from macports-tickets@… to digdog@…

comment:3 Changed 8 years ago by alakazam@…

I have reproduced this bug ; it also occurs with the mate command line tool from TextMate.

The following blog posts are relevant to this issue, and the comments expand on the problem :

comment:4 Changed 8 years ago by cpettitt@…

  • Cc cpettitt@… added

Cc Me!

comment:5 Changed 8 years ago by cpettitt@…

pbcopy and pbpaste are also broken since this change: http://trac.macports.org/changeset/45746 (4.0.3_2).

I'm reverting back to 4.0.3_1 for now as well.

comment:6 Changed 8 years ago by raimue (Rainer Müller)

By applying Apple's patches we got to the same state as the system screen, which is broken in the same way. On the other hand, attach/detach was broken without these patches (#13732).

comment:7 Changed 8 years ago by rectalogic (Andrew Wason)

Apparently it is the call to _vprocmgr_move_subset_to_user in Apples patches (to migrate to a background session) that is the cause of all these issues.

http://metastatic.org/text/Concern/tag/textmate/ http://lists.apple.com/archives/darwin-dev/2008/Jan/msg00218.html

comment:8 Changed 8 years ago by khalsah@…

  • Cc khalsah@… added

Cc Me!

comment:9 Changed 8 years ago by dan@…

  • Cc dan@… added

Cc Me!

comment:10 Changed 8 years ago by noah.easterly@…

  • Cc noah.easterly@… added

Cc Me!

comment:11 Changed 8 years ago by macports@…

  • Cc macports@… added

Cc Me!

comment:12 Changed 8 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

comment:13 Changed 8 years ago by lhunath@…

  • Cc lhunath@… added

Cc Me!

comment:14 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

  • Cc jeremyhu@… added

Cc Me!

comment:15 Changed 8 years ago by macports@…

  • Cc macports@… added

Cc Me!

comment:16 Changed 8 years ago by joel.chippindale@…

  • Cc joel.chippindale@… added

Cc Me!

comment:17 Changed 8 years ago by joel.chippindale@…

comment:18 Changed 7 years ago by gdelfino@…

  • Cc gdelfino@… added

Cc Me!

comment:19 Changed 7 years ago by gdelfino@…

  • Cc gdelfino@… removed

Cc Me!

comment:20 Changed 7 years ago by gdelfino@…

  • Cc gdelfino@… added

Cc Me!

comment:21 Changed 7 years ago by rtlechow@…

  • Cc rtlechow@… added

Cc Me!

comment:22 Changed 7 years ago by macports@…

  • Cc macports@… removed

Cc Me!

comment:23 Changed 7 years ago by macports@…

  • Cc macports@… added

Cc Me!

comment:24 Changed 7 years ago by tobypeterson

  • Resolution set to wontfix
  • Status changed from new to closed

There is no resolution for this ticket. Without that call, screen does not function in a very critical way - it doesn't persist if you log out. I'd consider that a much more important feature than being able to use pbcopy. Furthermore, this is fixed in SnowLeopard.

wontfix

comment:25 Changed 7 years ago by lhunath@…

Does that mean that the patch that the situation is black or white? Either we apply the patch or we don't? The whole point for this ticket is to find a middle way; applying the functionality introduced by the patch while not breaking the existing functionality which involves any communication between the terminal and apple utilities (this is definitely not a case of just pbcopy being broken).

comment:26 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

The problem is with the behavior of launchd on Leopard. In essence, on Leopard, each login has its own separate launchd environment. On SL, it is per-user (thus you will share a launchd environment with your console login when you login via ssh or get a new login environment via screen). That is essentially the root of the problem here. If you're interested, Damien Sorresso gave a nice talk at WWDC this summer about the changes in SL's launchd. I believe either a webcast or slides may be available in Apple's dev-central...

Note: See TracTickets for help on using tickets.