Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#18380 closed defect (fixed)

rpm51: Error: port activate failed: Not a directory

Reported by: ryandesign (Ryan Schmidt) Owned by: afb@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: n3npq@…, MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port:

Description

rpm51 fails to activate, saying

Error: port activate failed: Not a directory

Probably a problem with whatever it's doing with Python.

This problem causes MacPorts to activate all files in the port, but not register the port as active, so that's quite bad. (All the files are thus orphaned.)

Attachments (1)

Portfile.diff (365 bytes) - added by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by afb@…

Sounds more like a MacPorts bug to me ?

DEBUG: Adding file to file_map: /opt/local/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/rpm/__init__.py for: rpm51
DEBUG: Not a directory
    while executing
"filemap set file_map $file $port"
    (procedure "receipt_flat::register_file" line 11)
    invoked from within
"${macports::registry.format}::register_file $file $port"
    (procedure "registry::register_file" line 3)
    invoked from within
"registry::register_file $file $name"
    (procedure "portimage::activate" line 65)
    invoked from within
"portimage::activate $portname [composite_version $portversion [array get variations]] [array get options]"
Error: port activate failed: Not a directory

comment:2 Changed 12 years ago by afb@…

The subpath that is not a directory is:

/opt/local/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5 -> /opt/local/lib/python2.5

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

I believe it is considered a deliberate behavior of MacPorts and not a bug. I forget where that discussion took place but perhaps Googling "not a directory" would find it. If not, ask macports-dev and I'm sure someone will recall. I see related ticket #17998.

comment:4 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Python 2.5 now installs as a hybrid Framework and library installation.
Changing this now would require a fair amount of effort (see #16334).
Ports like boost and graphviz simply work around it.

Attached is a proposed solution for rmp51.

Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Attachment: Portfile.diff added

comment:5 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:6 Changed 12 years ago by afb@…

Port: rpm51 removed
Resolution: fixed
Status: newclosed

Fixed, r46817.

That MacPorts python's distutils are broken isn't really a RPM problem, though.

comment:7 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.