Opened 16 years ago

Closed 15 years ago

#1845 closed defect (invalid)

BUG: libevent weof tests fail

Reported by: bhines@… Owned by: tobypeterson
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

This occurs on OSX, unknown if it occurs on OD or pure darwin. I believe as a result of this scanssh 2.0 does not work.

Running tests: KQUEUE

test-eof: OKAY test-weof: FAILED test-time: OKAY regress: OKAY

POLL

test-eof: OKAY test-weof: FAILED test-time: poll.c:282: failed assertion `pArray != (struct pollfd *) NULL'

./test.sh: line 59: 15548 Abort trap ./test-time >/dev/null FAILED

regress: OKAY

SELECT

test-eof: OKAY test-weof: FAILED test-time: OKAY regress: OKAY

RTSIG Skipping test EPOLL Skipping test

Change History (6)

comment:1 Changed 15 years ago by dornseif@…

I can't reproduce this bug with 0.8 0.9 or 1.0.

comment:2 Changed 15 years ago by bhines@…

indeed, seems to work now with the current dev tools + 10.3.7, suggest closing.

-Ben

comment:3 Changed 15 years ago by toby@…

Very, very odd. If I add:

test.run yes test.target verify

...then it fails on 'port -d test'. But if I cd to to the source directory and run 'make verify' manually, the test passes.

comment:4 Changed 15 years ago by snu@…

Summary: All libevent weof tests failBUG: libevent weof tests fail

comment:5 Changed 15 years ago by mww@…

Owner: changed from fkr@… to toby@…

is this one still valid? (assigning to current maintainer)

comment:6 Changed 15 years ago by toby@…

Resolution: invalid
Status: newclosed

Same results. Since it only happens from within port, I don't think it's truly an issue.

Note: See TracTickets for help on using tickets.