Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#18494 closed defect (duplicate)

xpdf 3.02 installed on powerpc running 10.5.6 fails to work

Reported by: draine@… Owned by: ghosthound
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: xpdf

Description (last modified by mf2k (Frank Schima))

%% port -d install xpdf

appeared to run successfully on powerpc running osx 10.5.6 installed in /opt/local/bin/xpdf However, when I try to use xpdf I get errors

draine@ourania:~/work/book> xpdf book.pdf
Error: No paper information available - using defaults
Xlib:  extension "Generic Event Extension" missing on display "/tmp/launch-ogw8t2/:0".
Warning: Widget must be a VendorShell.
Error: attempt to add non-widget child "dsm" to parent "xpdf" which supports only widgets

Attachments (1)

port.install.xpdf.log.gz (6.0 KB) - added by draine@… 12 years ago.
gzipped output from %% port -d install xpdf

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by draine@…

Attachment: port.install.xpdf.log.gz added

gzipped output from %% port -d install xpdf

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: xpdf removed
Owner: changed from macports-tickets@… to ricci@…

comment:2 Changed 12 years ago by apsmith@…

I see this same "Xlib: extension "Generic Event Extension" missing ..." with many of the X11 program in macports that I've tried: xpdf, xmgrace, xdvi. However, the ghostscript (gs) X mode works ok.

This is on a MacBook Pro, OS X 10.5.6. I just installed macports yesterday (used to have Darwin Ports on a previous laptop so I knew how it worked); I've done a number of installs and upgrades, and port outdated now shows nothing to be outdated. I'm using the Mac OS X11 server. Not sure what other diagnostics would be helpful, but I downloaded macports specifically to use Grace and that definitely seems to be broken right now!

comment:3 Changed 12 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

Duplicate of #18114.

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.