Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#18496 closed defect (invalid)

gnome-control-center @2.24.0.1 - Configure Blocked by Outdated gnome-doc-utils Port

Reported by: ctempleton3@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: gnome-doc-utils, gnome-control-center

Description

I can not configure gnome-control-center due to the dependancy gnome-doc-utils is outdated and blocking the config. Please update gnome-doc-utils and indicate the minimum version requirement in gnome-control center.

configure: error: gnome-doc-utils >= 0.3.2 not found
$ port installed gnome-doc-utils
The following ports are currently installed:
  gnome-doc-utils @0.14.2_0 (active)
$ port info gnome-doc-utils
gnome-doc-utils @0.14.2 (gnome)

gnome-doc-utils is a collection of documentation utilities for the Gnomeproject. Notably, it contains utilities for building
documentation andall auxiliary files in your source tree, and it contains the DocBookXSLT stylesheets that were once distributed
with Yelp.
Homepage:    http://www.gnome.org/

Build Dependencies:   pkgconfig, perl5, p5-xml-parser
Library Dependencies: gettext, libiconv, libxml2, libxslt, py25-hashlib, py25-libxml2, python25
Runtime Dependencies: docbook-xml, docbook-xsl, rarian, iso-codes
Platforms:            darwin
Maintainers:          nomaintainer@macports.org
$ port livecheck gnome-doc-utils
$

Change History (6)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Port: gnome-doc-utils gnome-control-center added

comment:2 Changed 12 years ago by ctempleton3@…

Here is more detail on the problem I am encountering:

$ sudo port -tv install gnome-control-center
--->  Fetching gnome-control-center
--->  Verifying checksum(s) for gnome-control-center
--->  Checksumming gnome-control-center-2.24.0.1.tar.bz2
--->  Extracting gnome-control-center
--->  Extracting gnome-control-center-2.24.0.1.tar.bz2
--->  Configuring gnome-control-center
-- 15:bash -- time-stamp -- Feb/15/09  1:18:31 --
-- 15:bash -- time-stamp -- Feb/15/09  1:24:49 --
execve	/usr/bin/sed
execve	/bin/ls
checking whether build environment is sane... execve	/bin/sleep
execve	/usr/bin/sed
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... execve	/usr/bin/sed
execve	/bin/rm
checking whether to enable maintainer-specific portions of Makefiles... no
execve	/bin/cat
execve	/bin/rm
execve	/usr/bin/gcc-4.0
checking whether the C compiler works... execve	/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-control-center/work/gnome-control-center-2.24.0.1/./a.out
execve	/bin/rm
checking for suffix of executables... execve	/usr/bin/gcc-4.0
execve	/bin/rm
checking whether we are using the GNU C compiler... execve	/bin/cat
checking whether /usr/bin/gcc-4.0 accepts -g... execve	/bin/cat
checking for /usr/bin/gcc-4.0 option to accept ISO C89... execve	/bin/cat
checking dependency style of /usr/bin/gcc-4.0... execve	/bin/mkdir
checking for library containing strerror... execve	/bin/cat
checking for gcc... (cached) /usr/bin/gcc-4.0
execve	/usr/bin/gcc-4.0
checking whether /usr/bin/gcc-4.0 accepts -g... (cached) yes
checking for /usr/bin/gcc-4.0 option to accept ISO C89... (cached) none needed
checking dependency style of /usr/bin/gcc-4.0... (cached) gcc3
checking whether /usr/bin/gcc-4.0 and cc understand -c and -o together... execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/bin/cat
checking for egrep... execve	/usr/bin/grep
checking for ANSI C header files... execve	/bin/cat
execve	/bin/cat
checking host system type... powerpc-apple-darwin8.11.0
checking for a sed that does not truncate output... dep_check	/opt/local/bin/gsed
checking for ld used by /usr/bin/gcc-4.0... execve	/usr/bin/gcc-4.0
checking if the linker (/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld) is GNU ld... execve	/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld
checking for /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld option to reload object files... -r
checking for BSD-compatible nm... execve	/usr/bin/nm
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/sed
checking dlfcn.h presence... execve	/bin/cat
checking for dlfcn.h... yes
execve	/usr/bin/sed
checking whether /usr/bin/g++-4.0 accepts -g... execve	/bin/cat
checking dependency style of /usr/bin/g++-4.0... execve	/bin/mkdir
checking how to run the C++ preprocessor... execve	/bin/cat
execve	/bin/cat
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
execve	/bin/rm
checking whether  accepts -g... execve	/bin/cat
checking the maximum length of command line arguments... execve	/usr/sbin/sysctl
checking command to parse /usr/bin/nm -p output from /usr/bin/gcc-4.0 object... execve	/usr/bin/nm
checking for objdir... execve	/bin/rm
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
execve	/usr/bin/sed
checking for nmedit... nmedit
checking for -single_module linker flag... execve	/usr/bin/gcc-4.0
checking for -exported_symbols_list linker flag... execve	/bin/cat
execve	/usr/bin/gcc-4.0
checking for /usr/bin/gcc-4.0 option to produce PIC... -fno-common
checking if /usr/bin/gcc-4.0 PIC flag -fno-common works... execve	/usr/bin/sed
checking if /usr/bin/gcc-4.0 static flag -static works... execve	/usr/bin/gcc-4.0
checking if /usr/bin/gcc-4.0 supports -c -o file.o... execve	/bin/rm
checking whether the /usr/bin/gcc-4.0 linker (/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld) supports shared libraries... execve	/usr/bin/sed
checking dynamic linker characteristics... execve	/usr/bin/gcc-4.0
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... execve	/usr/bin/strip
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
execve	/usr/bin/sed
execve	/usr/bin/sed
execve	/usr/bin/g++-4.0
checking if the linker (/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld) is GNU ld... execve	/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld
checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld) supports shared libraries... yes
execve	/bin/cat
checking if /usr/bin/g++-4.0 PIC flag -fno-common works... execve	/usr/bin/sed
checking if /usr/bin/g++-4.0 static flag -static works... execve	/usr/bin/g++-4.0
checking if /usr/bin/g++-4.0 supports -c -o file.o... execve	/bin/rm
checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin8.11.0 dyld
(cached) (cached) checking how to hardcode library paths into programs... immediate
execve	/usr/bin/sed
execve	/usr/bin/sed
configure: error: gnome-doc-utils >= 0.3.2 not found
execve	/bin/cat
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-control-center/work/gnome-control-center-2.24.0.1" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man --disable-hal --enable-gstreamer --disable-scrollkeeper --disable-update-mimedb --disable-update-desktopdb --disable-schemas-install " returned error 1
Command output: checking for -single_module linker flag... execve	/usr/bin/gcc-4.0
Warning: the following items did not execute (for gnome-control-center): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.archive org.macports.install
Error: Status 1 encountered during processing.
$

comment:3 Changed 12 years ago by jmroot (Joshua Root)

The problem is not that gnome-doc-utils is outdated, 0.14.2 is much more recent than 0.3.2. Also, why are you using trace mode? Are you aware that it is not perfect and can cause failures? The preferred flag for producing debug output is simply -d.

comment:4 Changed 12 years ago by ctempleton3@…

Yep you are right. I understand there revision scheme now. I mistakenly added a '.' in my mind when I looked at the reversion number (aka, 0.1.4.2 instead of 0.14.2).

Also, I didn't know that a trace could block a build.

Please close this ticket as I have entered Ticket #18503 to replace this ticket due to the revision number not blocking the build.

Thanks,

Charles III

comment:5 Changed 12 years ago by dbevans (David B. Evans)

Resolution: invalid
Status: newclosed

Closing per reporter request

comment:6 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.