Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#18517 closed defect (worksforme)

GIMP v2.6.4 and v2.6.5 causes fatal hang-up shortly after loading image file.

Reported by: sarah.bearse@… Owned by: dbevans (David B. Evans)
Priority: High Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: gimp2

Description

I used macports to download and install GIMP v2.6.4 a few days ago, and found this issue (below). This morning I used macports to update to GIMP v2.6.5 and the issue persisted. I have filed a bug at the Gnome Bugzilla site as well.

Steps to reproduce:

  1. Launch gimp from terminal ($open-x11 gimp)
  2. Open image file, any jpeg it doesn't seem to matter. Has also happened when selecting a new image file.
  3. Select any tool, seems to happen with particular frequency using the lasso but it has also happened after selecting 'File' menu. It does not seem to be consistently caused by any one selection, but the program always hangs. It cannot be used for any period longer than 2 minutes.

Stack trace: Because the program hangs and doesn't crash I cannot get a good report from gdb. If someone could provide guidance on how to produce a better stack trace please let me know!

After the app hangs the spinney ball will stay indefinitely. However, if I force-quit the application I receive the following.


Attaching to program: `/opt/local/bin/gimp', process 14124. Reading symbols for shared libraries ................................................................++++++++++++++++++++++++++++............+........++++++++++.......................................... done 0x9001f488 in select () (gdb) cont Continuing. .. .. Reading symbols for shared libraries . done Reading symbols for shared libraries . done .. .. Program exited with code 01. (gdb) thread apply all bt (gdb) bt No stack. (gdb) backtrace


System details: OS X 10.4.11 Powerbook G4 (PowerPC) X11 v1.1.3 Gimp v.2.6.5 (this also occurred in v2.6.4) Macports v1.7

Change History (10)

comment:1 Changed 12 years ago by sarah.bearse@…

Cc: sarah.bearse@… added

Cc Me!

comment:2 Changed 12 years ago by dbevans (David B. Evans)

Owner: changed from macports-tickets@… to devans@…
Status: newassigned

comment:3 Changed 12 years ago by sarah.bearse@…

Reported on Bugzilla Gnome as: Bug 572059 – Gimp v2.6.4 and v2.6.5 causes fatal hang-up shortly after loading image file.

comment:4 Changed 12 years ago by dbevans (David B. Evans)

Thanks for the report. Have tried to reproduce the problem here but without any luck. My test system is 10.4.11 G4 ppc as well and I have tried with both the Apple supplied X11.app and the newer xorg-server port (xorg-server @1.4.2-apple32_0+macosx).

As I understand your report, the problem is somewhat random but occurs when operating on the image within a few minutes? Is there a very specific set of operations that will repeatedly cause the problem? I've played with lasso, etc as you suggest. Are you using a specific image or just any jpeg or does it also happen with other image types?

Am open to suggestions but now sure what to try next. Will watch the bugzilla report and see what turns up.

Would be useful if someone else can reproduce this problem.

comment:5 Changed 12 years ago by sarah.bearse@…

There is not a specific set of operations that will cause the hang-up, but it seems to be linked to clicking on any of the toolbars (either to select a tool, or to Save the image, or any other toolbar selection). I had believed it was the Lasso tool at first, but then experienced issues after any toolbar selection that I tried. Sometimes it can take up to two minutes of various operations before it will hang, so it is not an immediate failure but it always occurs.

I can reproduce this issue with any jpeg, I've tried four different images, it has also occurred after creating a new image file, after a few moments/minutes it will hang-up.

I would like to be able to provide you a stack trace previous to the hang-up, but I'm not too savvy on how to do this. GIMP does not hard-crash, instead X11 becomes non-responsive requiring a force quit to end the app. When I do this I get a very lame backtrace using GDB. If you could point me towards some info on providing better stack traces I could get you better information to work with?

comment:6 Changed 12 years ago by dbevans (David B. Evans)

Port: gimp2 added

I'm not sure I can give you any help with gdb but you may get more interesting diagnostic messages if you just type the command gimp in an xterm rather than use open-x11. Should at least get some X11 warning messages. I assume you have the various xorg-* files installed or are you using the +system_x11 variant?

comment:7 Changed 12 years ago by dbevans (David B. Evans)

Cc: sarah.bearse@… removed

Removing CC as reporter is automatically copied.

comment:8 Changed 12 years ago by sarah.bearse@…

Here is the output when opening directly from xterm:

$ /opt/local/bin/gimp

Xlib: extension "Generic Event Extension" missing on display ":0.0". Xlib: extension "RANDR" missing on display ":0.0". Xlib: extension "Generic Event Extension" missing on display ":0.0". Xlib: extension "Generic Event Extension" missing on display ":0.0".

I believe that I have the various xorg-* files installed ... but, I did not do it manually. $locate xorg

yields a ton of files in /opt/local/var/macports/sources | distfiles | receipts.

I am starting to think that the issue is due to an X11 bug. I have noticed that xterm pretty consistently crashes whether GIMP is running or not. I filed a plea for help in the Apple forum. I have tried to uninstall v1.1.3, reinstall v1.0 and update back up to v1.1.3, there has been no change in behavior.

comment:9 Changed 12 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: assignedclosed

The extension missing errors are normal and harmless.

To see what you have installed

port installed xorg-\*

However, it does look like you have something going on on this computer at the system level. I suspect that you are having memory problems (not enough memory/not enough vm swap space) that is causing the system to be tied up swapping memory all time. So not really a hang but not really progressing either.

Will close this as "worksforme" right now but if you can come up with something that looks like a smoking gun for gimp2, please feel free to open a new ticket.

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.