Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#18522 closed defect (wontfix)

subversion 1.5.5 configure error on OSX 10.5

Reported by: henuyken@… Owned by: danielluke (Daniel J. Luke)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: subversion

Description (last modified by mf2k (Frank Schima))

Configuring subversion
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.5.5" && ./configure --prefix=/opt/local --with-apr=/opt/local/bin/apr-1-config --with-apr-util=/opt/local/bin/apu-1-config --mandir=\${prefix}/share/man --disable-neon-version-check --with-serf=/opt/local --with-sasl=/opt/local --with-apxs=/opt/local/apache2/bin/apxs --disable-mod-activation -
-without-neon --without-berkeley-db --with-apxs=/opt/apache2/bin/apxs --disable-mod-activation --disable-keychain " returned error 1
Command output: configure: Configuring Subversion 1.5.5
configure: creating config.nice
checking for gcc... /usr/bin/gcc-4.0
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are
 using the GNU C compiler... yes
checking whether /usr/bin/gcc-4.0 accepts -g... yes
checking for /usr/bin/gcc-4.0 option to accept ISO C89... none needed
checking how to run the C preprocessor... /usr/bin/cpp-4.0
checking build system type... powerpc-apple-darwin9.6.0
checking host system type... powerpc-apple-darwin9.6.0
checking target system type... powerpc-apple-darwin9.6.0
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking whether ln -s 
works... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for static Apache module support... no
checking for Apache module support via DSO through APXS... ./configure: line 3936: /opt/apache2/bin/apxs: No such file or directory
configure: error: no - APXS refers to an old version of Apache
                     Unable to locate /mod_dav.h
Error: Status 1 encountered during processing.
Executing: /opt/local/bin/port install subversion +bash_completion +darwin_7 +mac_os_x_server_mod_dav_svn +mod_dav_svn +no_bdb +no_neon +tools +unicode_path

Change History (6)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to dluke@…
Port: subversion added

comment:2 Changed 12 years ago by danielluke (Daniel J. Luke)

Resolution: wontfix
Status: newclosed

The problem appears to be with the apache in /opt/apache2

You are building with +mac_os_x_server_mod_dav_svn

That variant is unsupported. You may be able to fix your apache2 install (as it appears to be broken), but I would advise you to use the macports-provided apache2 instead.

comment:3 Changed 12 years ago by henuyken@…

This subversion install and all its dependencies were MacPorts intalls, including Apache2. If MacPorts was building with +mac_os_x_server_mod_dav_svn it was configured to do so. I monitored the process and MacPorts installed its own version of apache2. I did not alter any of it. Could MacPorts have a problem with the stock install of apache2 on 10.5?

comment:4 in reply to:  3 Changed 12 years ago by danielluke (Daniel J. Luke)

The log you posted clearly indicates the selection of +mac_os_x_server_mod_dav_svn - this does not get selected by default, you must have selected it at some point in time.

From the log you posted: Executing: /opt/local/bin/port install subversion +bash_completion +darwin_7 +mac_os_x_server_mod_dav_svn +mod_dav_svn +no_bdb +no_neon +tools +unicode_path

The log also indicates that the apache2 install being built against is in /opt/apache2 which is not the macports-provided apache location (but it is the one that that variant attempts to use).

I recommend cleaning subversion and building again without +mac_os_x_server_mod_dav_svn:

port clean --all subversion port -dv install subversion

comment:5 Changed 12 years ago by henuyken@…

You are correct. I was using Porticus GUI late at night and was not paying close enough attention. Thanks for the reply.

comment:6 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.