Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#18537 closed defect (fixed)

svn 1.5.5 bus error

Reported by: asbjorn@… Owned by: danielluke (Daniel J. Luke)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: svn bus error Cc: asbjorn@…
Port: subversion

Description

After successfully installing SVN 1.5.5 without any hiccups or error messages, all I get no matter which command I try to issue (even --help!) is the following error message:

Bus error

Followed by the following OS X dialog message:

The application svn quit unexpectedly

2009-018 21:03:39 +0100

EXC_BAD_ACCESS (SIGBUS)
KERN_PROTECTION_FAILURE at
0x0000000000000010

Thread 0 Crashed:
0    par_palloc + 26
1    apr_array_make + 31
2    main + 232
3    start + 54

Choosing "report" in this dialog gives the following "Problem Details":

Process:         svn [57719]
Path:            /opt/local/bin/svn
Identifier:      svn
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  bash [8956]

Date/Time:       2009-02-18 20:20:33.729 +0100
OS Version:      Mac OS X 10.5.6 (9G55)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000010
Crashed Thread:  0

Thread 0 Crashed:
0   libapr-0.0.dylib              	0x002e584a apr_palloc + 26
1   libapr-0.0.dylib              	0x002d6e7f apr_array_make + 31
2   svn                           	0x00009188 main + 232
3   svn                           	0x00001e16 start + 54

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x00000018  ebx: 0x000090b7  ecx: 0x00000000  edx: 0x01010a18
  edi: 0x00000000  esi: 0x00000000  ebp: 0xbffff588  esp: 0xbffff550
   ss: 0x0000001f  efl: 0x00010206  eip: 0x002e584a   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037
  cr2: 0x00000010

Binary Images:
    0x1000 -    0x1dffb +svn ??? (???) /opt/local/bin/svn
   0x28000 -    0x2cffa +libsvn_ra-1.0.dylib ??? (???) /opt/local/lib/libsvn_ra-1.0.dylib
   0x3c000 -    0x6cfff +libsvn_client-1.0.dylib ??? (???) /opt/local/lib/libsvn_client-1.0.dylib
   0x78000 -    0xa9ffb +libsvn_wc-1.0.dylib ??? (???) /opt/local/lib/libsvn_wc-1.0.dylib
   0xb4000 -    0xbbffd +libsvn_diff-1.0.dylib ??? (???) /opt/local/lib/libsvn_diff-1.0.dylib
   0xc0000 -    0xc3ffe +libsvn_ra_local-1.0.dylib ??? (???) /opt/local/lib/libsvn_ra_local-1.0.dylib
   0xc8000 -    0xe6fff +libsvn_repos-1.0.dylib ??? (???) /opt/local/lib/libsvn_repos-1.0.dylib
   0xee000 -    0xf0ff4 +libsvn_fs-1.0.dylib ??? (???) /opt/local/lib/libsvn_fs-1.0.dylib
   0xf5000 -   0x10dff4 +libsvn_fs_fs-1.0.dylib ??? (???) /opt/local/lib/libsvn_fs_fs-1.0.dylib
  0x115000 -   0x134fff +libsvn_fs_base-1.0.dylib ??? (???) /opt/local/lib/libsvn_fs_base-1.0.dylib
  0x13e000 -   0x13eff6 +libsvn_fs_util-1.0.dylib ??? (???) /opt/local/lib/libsvn_fs_util-1.0.dylib
  0x142000 -   0x151ffd +libsvn_ra_svn-1.0.dylib ??? (???) /opt/local/lib/libsvn_ra_svn-1.0.dylib
  0x158000 -   0x169ffb +libsasl2.2.dylib ??? (???) /opt/local/lib/libsasl2.2.dylib
  0x16f000 -   0x178fe3  libpam.1.dylib ??? (???) <d7fa99b05b24b847372a4790b608f08c> /usr/lib/libpam.1.dylib
  0x17e000 -   0x195ff3 +libsvn_ra_neon-1.0.dylib ??? (???) /opt/local/lib/libsvn_ra_neon-1.0.dylib
  0x19e000 -   0x1b8fff +libsvn_ra_serf-1.0.dylib ??? (???) /opt/local/lib/libsvn_ra_serf-1.0.dylib
  0x1c1000 -   0x1c8ff9 +libserf-0.0.dylib ??? (???) /opt/local/lib/libserf-0.0.dylib
  0x1d0000 -   0x1defef +libaprutil-0.0.dylib ??? (???) /opt/local/lib/libaprutil-0.0.dylib
  0x1e6000 -   0x2bbfef +libdb-4.4.dylib ??? (???) /opt/local/lib/db44/libdb-4.4.dylib
  0x2d2000 -   0x2e7fee +libapr-0.0.dylib ??? (???) /opt/local/lib/libapr-0.0.dylib
  0x2f2000 -   0x2f9ff2 +libsvn_delta-1.0.dylib ??? (???) /opt/local/lib/libsvn_delta-1.0.dylib
  0x2fe000 -   0x329fff +libsvn_subr-1.0.dylib ??? (???) /opt/local/lib/libsvn_subr-1.0.dylib
  0x336000 -   0x34aff3 +libaprutil-1.0.dylib ??? (???) /opt/local/lib/libaprutil-1.0.dylib
  0x353000 -   0x44dfef +libdb-4.6.dylib ??? (???) /opt/local/lib/db46/libdb-4.6.dylib
  0x462000 -   0x47bfef +libapr-1.0.dylib ??? (???) /opt/local/lib/libapr-1.0.dylib
  0x486000 -   0x49dfff +libneon.27.dylib ??? (???) /opt/local/lib/libneon.27.dylib
  0x4a6000 -   0x4defeb +libssl.0.9.8.dylib ??? (???) <344b31c8167d85cb6c3f30ee35526d6f> /opt/local/lib/libssl.0.9.8.dylib
  0x4f2000 -   0x5f4fe7 +libcrypto.0.9.8.dylib ??? (???) <afefa07a5b9a28ef7765ddd9a45e200f> /opt/local/lib/libcrypto.0.9.8.dylib
  0x652000 -   0x662ffd +libz.1.dylib ??? (???) /opt/local/lib/libz.1.dylib
  0x667000 -   0x683fe3 +libexpat.1.dylib ??? (???) /opt/local/lib/libexpat.1.dylib
  0x68b000 -   0x692ff3 +libintl.8.dylib ??? (???) /opt/local/lib/libintl.8.dylib
  0x697000 -   0x78eff0 +libiconv.2.dylib ??? (???) /opt/local/lib/libiconv.2.dylib
0x8fe00000 - 0x8fe2db43  dyld 97.1 (???) <100d362e03410f181a34e04e94189ae5> /usr/lib/dyld
0x90475000 - 0x904acfff  com.apple.SystemConfiguration 1.9.2 (1.9.2) <8b26ebf26a009a098484f1ed01ec499c> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x90632000 - 0x906e2fff  edu.mit.Kerberos 6.0.12 (6.0.12) <685cc018c133668d0d3ac6a1cb63cff9> /System/Library/Frameworks/Kerberos.framework/Versions/A/Kerberos
0x90722000 - 0x907adfff  com.apple.framework.IOKit 1.5.1 (???) <f9f5f0d070e197a832d86751e1d44545> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x90c83000 - 0x90d0aff7  libsqlite3.0.dylib ??? (???) <11311084bc4be9d4555dfac74fe7218a> /usr/lib/libsqlite3.0.dylib
0x90d0b000 - 0x90fe5ff3  com.apple.CoreServices.CarbonCore 786.11 (786.11) <f06fe5d92d56ac5aa52d1ba182745924> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
0x910ea000 - 0x91115fe7  libauto.dylib ??? (???) <2072d673706bbe463ed2426af57a28d7> /usr/lib/libauto.dylib
0x91116000 - 0x911f7ff7  libxml2.2.dylib ??? (???) <d69560099d9eb32ba7f8a17baa65a28d> /usr/lib/libxml2.2.dylib
0x9123c000 - 0x91260fff  libxslt.1.dylib ??? (???) <0a9778d6368ae668826f446878deb99b> /usr/lib/libxslt.1.dylib
0x91983000 - 0x91aeaff3  libSystem.B.dylib ??? (???) <d68880dfb1f8becdbdac6928db1510fb> /usr/lib/libSystem.B.dylib
0x91c4d000 - 0x91d07fe3  com.apple.CoreServices.OSServices 226.5 (226.5) <2a135d4fb16f4954290f7b72b4111aa3> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
0x91d14000 - 0x91df4fff  libobjc.A.dylib ??? (???) <7b92613fdf804fd9a0a3733a0674c30b> /usr/lib/libobjc.A.dylib
0x91df5000 - 0x91e74ff5  com.apple.SearchKit 1.2.1 (1.2.1) <3140a605db2abf56b237fa156a08b28b> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
0x92197000 - 0x9219bfff  libmathCommon.A.dylib ??? (???) /usr/lib/system/libmathCommon.A.dylib
0x923c7000 - 0x923ceffe  libbsm.dylib ??? (???) <5582985a86ea36504cca31788bccf963> /usr/lib/libbsm.dylib
0x92af2000 - 0x92b4fffb  libstdc++.6.dylib ??? (???) <6106b1f2b0b303b06ae476253dbb5f3f> /usr/lib/libstdc++.6.dylib
0x92d77000 - 0x92dc0fef  com.apple.Metadata 10.5.2 (398.25) <e0572f20350523116f23000676122a8d> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
0x93008000 - 0x9313bfff  com.apple.CoreFoundation 6.5.5 (476.17) <4a70c8dbb582118e31412c53dc1f407f> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x93420000 - 0x93427fe9  libgcc_s.1.dylib ??? (???) <28a7cbc3a5ca2982d124668306f422d9> /usr/lib/libgcc_s.1.dylib
0x9390b000 - 0x9390bffa  com.apple.CoreServices 32 (32) <2760719f7a81e8c2bdfd15b0939abc29> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x9390d000 - 0x9391bffd  libz.1.dylib ??? (???) <545ca09467025f77131cfac09d8b9375> /usr/lib/libz.1.dylib
0x93a7e000 - 0x93a86fff  com.apple.DiskArbitration 2.2.1 (2.2.1) <42908e7ecc17a83cec4afef2850ec79e> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x93a87000 - 0x93aa5fff  libresolv.9.dylib ??? (???) <a8018c42930596593ddf27f7c20fe7af> /usr/lib/libresolv.9.dylib
0x95d29000 - 0x95ef7ff3  com.apple.security 5.0.4 (34102) <55dda7486df4e8e1d61505be16f83a1c> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x966e8000 - 0x966fefff  com.apple.DictionaryServices 1.0.0 (1.0.0) <7e9ff586b5c9d02b09e2a5527d98524f> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/DictionaryServices.framework/Versions/A/DictionaryServices
0x967a4000 - 0x96841fe4  com.apple.CFNetwork 422.15.2 (422.15.2) <80851410a5592b7c3b149b2ff849bcc1> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
0x96842000 - 0x968ceff7  com.apple.LaunchServices 290.3 (290.3) <6f9629f4ed1ba3bb313548e6838b2888> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
0x968d4000 - 0x96903fe3  com.apple.AE 402.3 (402.3) <4cb9ef65cf116d6dd424f0ce98c2d015> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
0x97103000 - 0x9723bff7  libicucore.A.dylib ??? (???) <18098dcf431603fe47ee027a60006c85> /usr/lib/libicucore.A.dylib
0xfffe8000 - 0xfffebfff  libobjc.A.dylib ??? (???) /usr/lib/libobjc.A.dylib
0xffff0000 - 0xffff1780  libSystem.B.dylib ??? (???) /usr/lib/libSystem.B.dylib

I have tried to reinstall Subversion several times without any success.

Attachments (1)

subversion.log (368.7 KB) - added by asbjorn@… 12 years ago.
Installation log

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by asbjorn@…

Cc: asbjorn@… added

Cc Me!

comment:2 Changed 12 years ago by mf2k (Frank Schima)

Cc: dluke@… removed
Owner: changed from macports-tickets@… to dluke@…

What version of Xcode are you running?

comment:3 Changed 12 years ago by danielluke (Daniel J. Luke)

Resolution: invalid
Status: newclosed

You appear to have a very old version of apr installed which is causing the problem.

Please do the following

port sync port -f uninstall apr apr-util subversion port clean --all apr apr-util subversion port -dv install subversion

and attach the output (and re-open this ticket) if you are still having a problem.

comment:4 Changed 12 years ago by asbjorn@…

I didn't uninstall exactly as prescribed because I had several versions of both apr and apr-util installed, so I instead uninstalled all of them. With a fresh take, I then tried to install subversion again, with the following result:

DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.5.5" && make all'
cd subversion/libsvn_ra_serf && /bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.5.5/libtool --tag=CC --silent --mode=link /usr/bin/gcc-4.0  -O2     -L/opt/local/lib    -L/opt/local/lib -L/opt/local/lib  -rpath /opt/local/lib -o libsvn_ra_serf-1.la  auth.lo blame.lo commit.lo getdate.lo getlocations.lo getlocationsegments.lo getlocks.lo locks.lo log.lo merge.lo mergeinfo.lo options.lo property.lo propfind_buckets.lo replay.lo serf.lo update.lo util.lo win32_auth_sspi.lo xml.lo ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la /opt/local/lib/libaprutil-1.la  -lexpat -liconv /opt/local/lib/libapr-1.la -lpthread /opt/local/lib/libserf-0.la -lintl  -framework Security -framework CoreFoundation -framework CoreServices
grep: /opt/local/lib/libaprutil-0.la: No such file or directory
sed: /opt/local/lib/libaprutil-0.la: No such file or directory
libtool: link: `/opt/local/lib/libaprutil-0.la' is not a valid libtool archive
make: *** [subversion/libsvn_ra_serf/libsvn_ra_serf-1.la] Error 1
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.5.5" && make all " returned error 2
Command output: cd subversion/libsvn_ra_serf && /bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.5.5/libtool --tag=CC --silent --mode=link /usr/bin/gcc-4.0  -O2     -L/opt/local/lib    -L/opt/local/lib -L/opt/local/lib  -rpath /opt/local/lib -o libsvn_ra_serf-1.la  auth.lo blame.lo commit.lo getdate.lo getlocations.lo getlocationsegments.lo getlocks.lo locks.lo log.lo merge.lo mergeinfo.lo options.lo property.lo propfind_buckets.lo replay.lo serf.lo update.lo util.lo win32_auth_sspi.lo xml.lo ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la /opt/local/lib/libaprutil-1.la  -lexpat -liconv /opt/local/lib/libapr-1.la -lpthread /opt/local/lib/libserf-0.la -lintl  -framework Security -framework CoreFoundation -framework CoreServices
grep: /opt/local/lib/libaprutil-0.la: No such file or directory
sed: /opt/local/lib/libaprutil-0.la: No such file or directory
libtool: link: `/opt/local/lib/libaprutil-0.la' is not a valid libtool archive
make: *** [subversion/libsvn_ra_serf/libsvn_ra_serf-1.la] Error 1

Warning: the following items did not execute (for subversion): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

It seems like subversion would like to reference version 0.1a of libaprutil for some crazy reason.

comment:5 Changed 12 years ago by asbjorn@…

PS: trying to reopen the ticket just yields "Warning: No permission to change ticket fields.".

comment:6 Changed 12 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: closedreopened

comment:7 Changed 12 years ago by danielluke (Daniel J. Luke)

Is that the full output?

If so, it looks like you didn't clean subversion before rebuilding again. It's trying to link with an old version of libaprutil.

If not, could you clean and re-run the build and attach the full output (including the configure stage). Could you also list which versions/variants of apr and apr-util you have installed?

comment:8 Changed 12 years ago by asbjorn@…

No, that's not the full output, but the last part of it and what I thought was relevant. I did clean everything before reinstalling. I'll clean and reinstall again and attach the full log (if it's not too big) once it's done.

Changed 12 years ago by asbjorn@…

Attachment: subversion.log added

Installation log

comment:9 Changed 12 years ago by asbjorn@…

Before installing subversion, I had no versions of apr or apr-util installed, but after the last failed installation I have apr @1.3.3_1 and apr-util @1.3.4_1. As far as I can tell, that's the latest version of both.

comment:10 in reply to:  9 Changed 12 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: reopenedclosed

Replying to asbjorn@…:

Before installing subversion, I had no versions of apr or apr-util installed, but after the last failed installation I have apr @1.3.3_1 and apr-util @1.3.4_1. As far as I can tell, that's the latest version of both.

Yep, looks like the problem is simply that serf was built against your old apr and needs to be rebuilt.

port -f uninstall serf subversion port clean --all serf subversion port -dv install serf subversion

should fix you up.

comment:11 Changed 12 years ago by asbjorn@…

Success! Serf was the bloody offender. Removing and reinstalling it did the trick. Thanks! :)

comment:12 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.