Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#18583 closed defect (fixed)

fetch.type svn fails on untrusted certificates

Reported by: ray.j@… Owned by: macports-tickets@…
Priority: Normal Milestone: MacPorts 1.8.0
Component: base Version: 1.7.0
Keywords: Cc: mike4004@…
Port: taglib-devel

Description

sudo port install  taglib-devel
--->  Fetching taglib-devel
Error: Target org.macports.fetch returned: Subversion check out failed
Error: Status 1 encountered during processing.

Change History (13)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Port: taglib-devel added

comment:2 Changed 12 years ago by raimue (Rainer Müller)

The actual error is in an external:

Fetching external item into 'taglib/admin'
svn: PROPFIND request failed on '/home/kde/branches/KDE/3.5/kde-common/admin'
svn: PROPFIND of '/home/kde/branches/KDE/3.5/kde-common/admin': Server certificate verification failed: issuer is not trusted (https://svn.kde.org)
Error: Target org.macports.fetch returned: Subversion check out failed

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:4 Changed 12 years ago by payam.minoofar@…

I'm experiencing this, too.

First, I get

Fetching external item into 'taglib/admin'
svn: PROPFIND request failed on '/home/kde/branches/KDE/3.5/kde-common/admin'
svn: PROPFIND of '/home/kde/branches/KDE/3.5/kde-common/admin': Server certificate verification failed: issuer is not trusted (https://svn.kde.org)
Error: Target org.macports.fetch returned: Subversion check out failed
Warning: the following items did not execute (for taglib-devel): org.macports.activate org.macports.fetch org.macports.extract org.macports.checksum org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: The following dependencies failed to build: taglib-devel taglib-extras
Error: Status 1 encountered during processing.

Then, I get,

[payam-imac:~] payam% sudo svn checkout https://svn.kde.org
Error validating server certificate for 'https://svn.kde.org:443':
 - The certificate is not issued by a trusted authority. Use the
   fingerprint to validate the certificate manually!
Certificate information:
 - Hostname: svn.kde.org
 - Valid: from Wed, 11 May 2005 18:08:21 GMT until Sat, 09 May 2015 18:08:21 GMT
 - Issuer: SVN, KDE e.V., Nuernberg, Bavaria, DE
 - Fingerprint: e1:e6:41:96:3c:eb:ae:78:e2:73:0d:a2:32:2f:6b:21:13:bf:3d:0f
(R)eject, accept (t)emporarily or accept (p)ermanently? p
svn: PROPFIND request failed on '/'
svn: PROPFIND of '/': 301 Moved Permanently (https://svn.kde.org)

comment:5 Changed 12 years ago by payam.minoofar@…

I should add that the company uses the St. Bernard iPrism censoring agent. Could this be the cause?

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

Summary: Taglib.devel fails to fetchtaglib-devel fails to fetch

comment:7 in reply to:  description Changed 12 years ago by tiago.freire@…

me too. [OFFTOPIC] Maybe it's what is causing kdepim4 and kdeutils4 to fail too? I am getting those 3 errors.

comment:8 Changed 12 years ago by mf2k (Frank Schima)

Cc: mike4004@… added

Cc reporter of dup #20138.

comment:9 in reply to:  8 ; Changed 12 years ago by mike4004@…

ok thanks adding the cert permantanent with 'sudo svn checkout https://svn.kde.org' helps

best regards, mike

comment:10 in reply to:  9 ; Changed 11 years ago by thedoobs@…

Replying to mike4004@…:

ok thanks adding the cert permantanent with 'sudo svn checkout https://svn.kde.org' helps

best regards, mike

yep, that worked for me as well...thanks!

comment:11 in reply to:  10 Changed 11 years ago by t_bernhart@…

Replying to thedoobs@…:

Replying to mike4004@…:

ok thanks adding the cert permantanent with 'sudo svn checkout https://svn.kde.org' helps

best regards, mike

yep, that worked for me as well...thanks!

Doesn't work here: I get the followeing, when trying to add the certificate manually:

sudo svn ls https://svn.kde.org
svn: Das Projektarchiv wurde permanent nach »http://websvn.kde.org/« verschoben; bitte umplatzieren

which means something like: The project archive has moved permanently to http://websvn.kde.org/; ...

sudo svn ls http://websvn.kde.org

did solve the problem. But the port taglib-devel seems to need a fix, right?

Thanks anyway

comment:12 Changed 11 years ago by jmroot (Joshua Root)

Component: portsbase
Milestone: MacPorts 1.8.0
Resolution: fixed
Status: newclosed
Summary: taglib-devel fails to fetchfetch.type svn fails on untrusted certificates

As of r54434, svn fetch always requires the subversion port so that --trust-server-cert can be used.

comment:13 Changed 11 years ago by illogic-al@…

Eh. I'm a little late on this I suppose. taglib-devel was fixed by upgrading to a version which doesn't use an svn external for the admin directory today (r56609). Quite by accident actually as i never knew about this report. Good that macports has a "better" solution though.

Note: See TracTickets for help on using tickets.