Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#18625 closed defect (invalid)

db46 build fails

Reported by: nigel@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: gnucash Cc:
Port: db46

Description

When building gnucash the build of db46 fails. I have cleaned and tried separately with the same failure.

A clean copy of MacPorts was started yesterday the main installs since are py25-wxpython and py25-matplotlib

The trace follows of cleaning followed by install and then the error trace.

nigel-kings-macbook-pro-15:Desktop nigelk$ sudo port clean db46
Password:
--->  Cleaning db46
nigel-kings-macbook-pro-15:Desktop nigelk$ sudo port install db46
--->  Fetching db46
--->  Verifying checksum(s) for db46
--->  Extracting db46
--->  Applying patches to db46
--->  Configuring db46
--->  Building db46
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/work/db-4.6.21/build_unix" && make all " returned error 2
Command output: /bin/sh ./libtool --mode=compile /usr/bin/g++-4.0 -c -I. -I../dist/.. -I/opt/local/include -O2 ../dist/../cxx/cxx_txn.cpp
 /usr/bin/g++-4.0 -c -I. -I../dist/.. -I/opt/local/include -O2 ../dist/../cxx/cxx_txn.cpp  -fno-common -DPIC -o .libs/cxx_txn.o
 /usr/bin/g++-4.0 -c -I. -I../dist/.. -I/opt/local/include -O2 ../dist/../cxx/cxx_txn.cpp -o cxx_txn.o >/dev/null 2>&1
/bin/sh ./libtool --mode=link /usr/bin/g++-4.0 -avoid-version -O2 -rpath /opt/local/lib/db46 -L/opt/local/lib \
	    -o libdb_cxx-4.6.la cxx_db.lo cxx_dbc.lo cxx_dbt.lo cxx_env.lo cxx_except.lo cxx_lock.lo cxx_logc.lo cxx_mpool.lo cxx_multi.lo cxx_seq.lo cxx_txn.lo mut_tas.lo  bt_compare.lo bt_conv.lo bt_curadj.lo bt_cursor.lo bt_delete.lo bt_method.lo bt_open.lo bt_put.lo bt_rec.lo bt_reclaim.lo bt_recno.lo bt_rsearch.lo bt_search.lo bt_split.lo bt_stat.lo bt_compact.lo bt_upgrade.lo btree_auto.lo hash.lo hash_auto.lo hash_conv.lo hash_dup.lo hash_meta.lo hash_method.lo hash_open.lo hash_page.lo hash_rec.lo hash_reclaim.lo hash_stat.lo hash_upgrade.lo hash_verify.lo qam.lo qam_auto.lo qam_conv.lo qam_files.lo qam_method.lo qam_open.lo qam_rec.lo qam_stat.lo qam_upgrade.lo qam_verify.lo rep_auto.lo rep_backup.lo rep_elect.lo rep_lease.lo rep_log.lo rep_method.lo rep_record.lo rep_region.lo rep_stat.lo rep_util.lo rep_verify.lo repmgr_stub.lo db_ovfl_vrfy.lo db_vrfy.lo db_vrfyutil.lo bt_verify.lo lock.lo lock_deadlock.lo lock_failchk.lo lock_id.lo lock_list.lo lock_method.lo lock_region.lo lock_stat.lo lock_timer.lo lock_util.lo mut_alloc.lo mut_failchk.lo mut_method.lo mut_region.lo mut_stat.lo  aes_method.lo crypto.lo mt19937db.lo rijndael-alg-fst.lo rijndael-api-fst.lo crdel_auto.lo crdel_rec.lo ctime.lo db.lo db_am.lo db_auto.lo db_byteorder.lo db_cam.lo db_cds.lo db_conv.lo db_dispatch.lo db_dup.lo db_err.lo db_getlong.lo db_idspace.lo db_iface.lo db_join.lo db_log2.lo db_meta.lo db_method.lo db_open.lo db_overflow.lo db_pr.lo db_rec.lo db_reclaim.lo db_remove.lo db_rename.lo db_ret.lo db_setid.lo db_setlsn.lo db_shash.lo db_stati.lo db_truncate.lo db_upg.lo db_upg_opd.lo dbm.lo dbreg.lo dbreg_auto.lo dbreg_rec.lo dbreg_stat.lo dbreg_util.lo env_alloc.lo env_config.lo env_failchk.lo env_file.lo env_globals.lo env_method.lo env_name.lo env_open.lo env_recover.lo env_region.lo env_register.lo env_stat.lo fileops_auto.lo fop_basic.lo fop_rec.lo fop_util.lo hash_func.lo hmac.lo hsearch.lo log.lo log_archive.lo log_compare.lo log_debug.lo log_get.lo log_method.lo log_put.lo log_stat.lo mkpath.lo mp_alloc.lo mp_bh.lo mp_fget.lo mp_fmethod.lo mp_fopen.lo mp_fput.lo mp_fset.lo mp_method.lo mp_mvcc.lo mp_region.lo mp_register.lo mp_resize.lo mp_stat.lo mp_sync.lo mp_trickle.lo os_abort.lo os_abs.lo os_alloc.lo os_clock.lo os_config.lo os_dir.lo os_errno.lo os_fid.lo os_flock.lo os_fsync.lo os_fzero.lo os_getenv.lo os_handle.lo os_map.lo os_method.lo os_mkdir.lo os_oflags.lo os_open.lo os_pid.lo os_region.lo os_rename.lo os_root.lo os_rpath.lo os_rw.lo os_seek.lo os_sleep.lo os_spin.lo os_stat.lo os_tmpdir.lo os_truncate.lo os_uid.lo os_unlink.lo os_yield.lo seq_stat.lo sequence.lo sha1.lo snprintf.lo txn.lo txn_auto.lo txn_chkpt.lo txn_failchk.lo txn_method.lo txn_rec.lo txn_recover.lo txn_region.lo txn_stat.lo txn_util.lo xa.lo xa_db.lo xa_map.lo 
/usr/bin/g++-4.0 -dynamiclib -single_module ${wl}-undefined ${wl}dynamic_lookup -o .libs/libdb_cxx-4.6.dylib  .libs/cxx_db.o .libs/cxx_dbc.o .libs/cxx_dbt.o .libs/cxx_env.o .libs/cxx_except.o .libs/cxx_lock.o .libs/cxx_logc.o .libs/cxx_mpool.o .libs/cxx_multi.o .libs/cxx_seq.o .libs/cxx_txn.o .libs/mut_tas.o .libs/bt_compare.o .libs/bt_conv.o .libs/bt_curadj.o .libs/bt_cursor.o .libs/bt_delete.o .libs/bt_method.o .libs/bt_open.o .libs/bt_put.o .libs/bt_rec.o .libs/bt_reclaim.o .libs/bt_recno.o .libs/bt_rsearch.o .libs/bt_search.o .libs/bt_split.o .libs/bt_stat.o .libs/bt_compact.o .libs/bt_upgrade.o .libs/btree_auto.o .libs/hash.o .libs/hash_auto.o .libs/hash_conv.o .libs/hash_dup.o .libs/hash_meta.o .libs/hash_method.o .libs/hash_open.o .libs/hash_page.o .libs/hash_rec.o .libs/hash_reclaim.o .libs/hash_stat.o .libs/hash_upgrade.o .libs/hash_verify.o .libs/qam.o .libs/qam_auto.o .libs/qam_conv.o .libs/qam_files.o .libs/qam_method.o .libs/qam_open.o .libs/qam_rec.o .libs/qam_stat.o .libs/qam_upgrade.o .libs/qam_verify.o .libs/rep_auto.o .libs/rep_backup.o .libs/rep_elect.o .libs/rep_lease.o .libs/rep_log.o .libs/rep_method.o .libs/rep_record.o .libs/rep_region.o .libs/rep_stat.o .libs/rep_util.o .libs/rep_verify.o .libs/repmgr_stub.o .libs/db_ovfl_vrfy.o .libs/db_vrfy.o .libs/db_vrfyutil.o .libs/bt_verify.o .libs/lock.o .libs/lock_deadlock.o .libs/lock_failchk.o .libs/lock_id.o .libs/lock_list.o .libs/lock_method.o .libs/lock_region.o .libs/lock_stat.o .libs/lock_timer.o .libs/lock_util.o .libs/mut_alloc.o .libs/mut_failchk.o .libs/mut_method.o .libs/mut_region.o .libs/mut_stat.o .libs/aes_method.o .libs/crypto.o .libs/mt19937db.o .libs/rijndael-alg-fst.o .libs/rijndael-api-fst.o .libs/crdel_auto.o .libs/crdel_rec.o .libs/ctime.o .libs/db.o .libs/db_am.o .libs/db_auto.o .libs/db_byteorder.o .libs/db_cam.o .libs/db_cds.o .libs/db_conv.o .libs/db_dispatch.o .libs/db_dup.o .libs/db_err.o .libs/db_getlong.o .libs/db_idspace.o .libs/db_iface.o .libs/db_join.o .libs/db_log2.o .libs/db_meta.o .libs/db_method.o .libs/db_open.o .libs/db_overflow.o .libs/db_pr.o .libs/db_rec.o .libs/db_reclaim.o .libs/db_remove.o .libs/db_rename.o .libs/db_ret.o .libs/db_setid.o .libs/db_setlsn.o .libs/db_shash.o .libs/db_stati.o .libs/db_truncate.o .libs/db_upg.o .libs/db_upg_opd.o .libs/dbm.o .libs/dbreg.o .libs/dbreg_auto.o .libs/dbreg_rec.o .libs/dbreg_stat.o .libs/dbreg_util.o .libs/env_alloc.o .libs/env_config.o .libs/env_failchk.o .libs/env_file.o .libs/env_globals.o .libs/env_method.o .libs/env_name.o .libs/env_open.o .libs/env_recover.o .libs/env_region.o .libs/env_register.o .libs/env_stat.o .libs/fileops_auto.o .libs/fop_basic.o .libs/fop_rec.o .libs/fop_util.o .libs/hash_func.o .libs/hmac.o .libs/hsearch.o .libs/log.o .libs/log_archive.o .libs/log_compare.o .libs/log_debug.o .libs/log_get.o .libs/log_method.o .libs/log_put.o .libs/log_stat.o .libs/mkpath.o .libs/mp_alloc.o .libs/mp_bh.o .libs/mp_fget.o .libs/mp_fmethod.o .libs/mp_fopen.o .libs/mp_fput.o .libs/mp_fset.o .libs/mp_method.o .libs/mp_mvcc.o .libs/mp_region.o .libs/mp_register.o .libs/mp_resize.o .libs/mp_stat.o .libs/mp_sync.o .libs/mp_trickle.o .libs/os_abort.o .libs/os_abs.o .libs/os_alloc.o .libs/os_clock.o .libs/os_config.o .libs/os_dir.o .libs/os_errno.o .libs/os_fid.o .libs/os_flock.o .libs/os_fsync.o .libs/os_fzero.o .libs/os_getenv.o .libs/os_handle.o .libs/os_map.o .libs/os_method.o .libs/os_mkdir.o .libs/os_oflags.o .libs/os_open.o .libs/os_pid.o .libs/os_region.o .libs/os_rename.o .libs/os_root.o .libs/os_rpath.o .libs/os_rw.o .libs/os_seek.o .libs/os_sleep.o .libs/os_spin.o .libs/os_stat.o .libs/os_tmpdir.o .libs/os_truncate.o .libs/os_uid.o .libs/os_unlink.o .libs/os_yield.o .libs/seq_stat.o .libs/sequence.o .libs/sha1.o .libs/snprintf.o .libs/txn.o .libs/txn_auto.o .libs/txn_chkpt.o .libs/txn_failchk.o .libs/txn_method.o .libs/txn_rec.o .libs/txn_recover.o .libs/txn_region.o .libs/txn_stat.o .libs/txn_util.o .libs/xa.o .libs/xa_db.o .libs/xa_map.o  -L/opt/local/lib  -install_name  /opt/local/lib/db46/libdb_cxx-4.6.dylib 
ar cru .libs/libdb_cxx-4.6.a  cxx_db.o cxx_dbc.o cxx_dbt.o cxx_env.o cxx_except.o cxx_lock.o cxx_logc.o cxx_mpool.o cxx_multi.o cxx_seq.o cxx_txn.o mut_tas.o bt_compare.o bt_conv.o bt_curadj.o bt_cursor.o bt_delete.o bt_method.o bt_open.o bt_put.o bt_rec.o bt_reclaim.o bt_recno.o bt_rsearch.o bt_search.o bt_split.o bt_stat.o bt_compact.o bt_upgrade.o btree_auto.o hash.o hash_auto.o hash_conv.o hash_dup.o hash_meta.o hash_method.o hash_open.o hash_page.o hash_rec.o hash_reclaim.o hash_stat.o hash_upgrade.o hash_verify.o qam.o qam_auto.o qam_conv.o qam_files.o qam_method.o qam_open.o qam_rec.o qam_stat.o qam_upgrade.o qam_verify.o rep_auto.o rep_backup.o rep_elect.o rep_lease.o rep_log.o rep_method.o rep_record.o rep_region.o rep_stat.o rep_util.o rep_verify.o repmgr_stub.o db_ovfl_vrfy.o db_vrfy.o db_vrfyutil.o bt_verify.o lock.o lock_deadlock.o lock_failchk.o lock_id.o lock_list.o lock_method.o lock_region.o lock_stat.o lock_timer.o lock_util.o mut_alloc.o mut_failchk.o mut_method.o mut_region.o mut_stat.o aes_method.o crypto.o mt19937db.o rijndael-alg-fst.o rijndael-api-fst.o crdel_auto.o crdel_rec.o ctime.o db.o db_am.o db_auto.o db_byteorder.o db_cam.o db_cds.o db_conv.o db_dispatch.o db_dup.o db_err.o db_getlong.o db_idspace.o db_iface.o db_join.o db_log2.o db_meta.o db_method.o db_open.o db_overflow.o db_pr.o db_rec.o db_reclaim.o db_remove.o db_rename.o db_ret.o db_setid.o db_setlsn.o db_shash.o db_stati.o db_truncate.o db_upg.o db_upg_opd.o dbm.o dbreg.o dbreg_auto.o dbreg_rec.o dbreg_stat.o dbreg_util.o env_alloc.o env_config.o env_failchk.o env_file.o env_globals.o env_method.o env_name.o env_open.o env_recover.o env_region.o env_register.o env_stat.o fileops_auto.o fop_basic.o fop_rec.o fop_util.o hash_func.o hmac.o hsearch.o log.o log_archive.o log_compare.o log_debug.o log_get.o log_method.o log_put.o log_stat.o mkpath.o mp_alloc.o mp_bh.o mp_fget.o mp_fmethod.o mp_fopen.o mp_fput.o mp_fset.o mp_method.o mp_mvcc.o mp_region.o mp_register.o mp_resize.o mp_stat.o mp_sync.o mp_trickle.o os_abort.o os_abs.o os_alloc.o os_clock.o os_config.o os_dir.o os_errno.o os_fid.o os_flock.o os_fsync.o os_fzero.o os_getenv.o os_handle.o os_map.o os_method.o os_mkdir.o os_oflags.o os_open.o os_pid.o os_region.o os_rename.o os_root.o os_rpath.o os_rw.o os_seek.o os_sleep.o os_spin.o os_stat.o os_tmpdir.o os_truncate.o os_uid.o os_unlink.o os_yield.o seq_stat.o sequence.o sha1.o snprintf.o txn.o txn_auto.o txn_chkpt.o txn_failchk.o txn_method.o txn_rec.o txn_recover.o txn_region.o txn_stat.o txn_util.o xa.o xa_db.o xa_map.o
ranlib: file: .libs/libdb_cxx-4.6.a(snprintf.o) has no symbols
ranlib .libs/libdb_cxx-4.6.a
ranlib: file: .libs/libdb_cxx-4.6.a(snprintf.o) has no symbols
creating libdb_cxx-4.6.la
(cd .libs && rm -f libdb_cxx-4.6.la && ln -s ../libdb_cxx-4.6.la libdb_cxx-4.6.la)
rm -f libdb_cxx.a
ln -s .libs/libdb_cxx-4.6.a libdb_cxx.a
/bin/sh ./libtool --mode=compile /usr/bin/gcc-4.0 -c -O2  -I../dist/.. -I/opt/local/include ../dist/../db_dump185/db_dump185.c
 /usr/bin/gcc-4.0 -c -O2 -I../dist/.. -I/opt/local/include ../dist/../db_dump185/db_dump185.c  -fno-common -DPIC -o .libs/db_dump185.o
../dist/../db_dump185/db_dump185.c: In function 'main':
../dist/../db_dump185/db_dump185.c:211: warning: assignment makes pointer from integer without a cast
../dist/../db_dump185/db_dump185.c:213: warning: assignment makes pointer from integer without a cast
../dist/../db_dump185/db_dump185.c:228: error: 'struct __db' has no member named 'seq'
../dist/../db_dump185/db_dump185.c:228: error: 'R_NEXT' undeclared (first use in this function)
../dist/../db_dump185/db_dump185.c:228: error: (Each undeclared identifier is reported only once
../dist/../db_dump185/db_dump185.c:228: error: for each function it appears in.)
../dist/../db_dump185/db_dump185.c:233: error: 'struct __db' has no member named 'seq'
../dist/../db_dump185/db_dump185.c: In function 'db_hash':
../dist/../db_dump185/db_dump185.c:261: error: 'struct __db' has no member named 'internal'
../dist/../db_dump185/db_dump185.c:263: error: 'struct __db' has no member named 'internal'
../dist/../db_dump185/db_dump185.c: In function 'db_btree':
../dist/../db_dump185/db_dump185.c:288: error: 'struct __db' has no member named 'internal'
make: *** [db_dump185.lo] Error 1

Error: Status 1 encountered during processing.
nigel-kings-macbook-pro-15:Desktop nigelk$ 

Change History (10)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Cc: nigel@… removed
Owner: changed from macports-tickets@… to blair@…

comment:2 Changed 12 years ago by blair (Blair Zajac)

If you have anything in /usr/local, please move it before building this port.

comment:3 Changed 12 years ago by nigel@…

I have the following in /usr/local. What do you mean by anything?

nigel-kings-macbook-pro-15:Desktop nigelk$ ll /usr/local
total 0
drwxr-xr-x    3 root    wheel     102 17 Oct  2007 OpenSourceLicenses
drwxr-xr-x    3 root    wheel     102 17 Oct  2007 OpenSourceVersions
drwxr-xr-x  122 nigelk  staff    4148 16 Feb 14:16 bin
drwxr-xr-x   29 nigelk  staff     986 18 Dec 07:41 include
drwxr-xr-x    6 root    wheel     204 18 Dec 07:41 info
drwxr-xr-x    3 root    wheel     102 28 Aug 23:56 juniper
drwxr-xr-x  197 nigelk  staff    6698 29 Dec 19:50 lib
drwxr-xr-x    4 nigelk  geneweb   136 18 Dec 07:41 libexec
drwxr-xr-x    5 root    wheel     170 18 Dec 07:41 man
drwxr-xr-x   14 nigelk  staff     476  9 Dec 14:22 share
drwxr-xr-x    9 root    wheel     306 17 Nov  2007 squid
drwxr-xr-x    3 root    wheel     102  7 Sep 06:55 texlive

comment:4 Changed 12 years ago by blair (Blair Zajac)

Do

mv /usr/local /usr/local-save port install db46 mv /usr/local-save /usr/local

comment:5 Changed 12 years ago by nigel@…

Thanks very much. That has worked. I now see on the email list the same recommendation. Thanks again.

comment:6 Changed 12 years ago by blair (Blair Zajac)

Resolution: invalid
Status: newclosed

Great!

comment:7 Changed 12 years ago by tim.becker@…

mv /usr/local /usr/local-save port install db46 mv /usr/local-save /usr/local

Am I the only one thinking this isn't a reasonable solution? Moving around OSX install files in order to make this --rather central-- port install, isn't really in the spirit of things, is it?

comment:8 Changed 12 years ago by blair (Blair Zajac)

Sure, it's not great solution.

Unfortunately, I don't have the cycles to see what the issue is and fix it, plus I don't have stuff in /usr/local.

Patches are welcome :)

comment:9 in reply to:  7 Changed 12 years ago by blb@…

Replying to tim.becker@…:

Am I the only one thinking this isn't a reasonable solution? Moving around OSX install files in order to make this --rather central-- port install, isn't really in the spirit of things, is it?

Note that /usr/local doesn't exist on a standard Mac OS X install. The problem is that the build tools (gcc etc) have a liking to /usr/local which can't be worked around with consistency.

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.