Opened 11 years ago

Closed 10 years ago

#18694 closed defect (wontfix)

vice fails to compile

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: build Cc:
Port: vice

Description

if /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I../../../../../src -I../../../../../src/arch/unix -I../../../../../src -I../../../../../src -I../../../../../src/drive -I../../../../../src/vdrive -I../../../../../src/c64 -I../../../../../src/c128 -I../../../../../src/vic20 -I../../../../../src/pet -I../../../../../src/cbm2 -I../../../../../src/arch/unix/x11  -I/opt/local/include  -I/usr/X11/include  -O2 -MT uimenu.o -MD -MP -MF ".deps/uimenu.Tpo" \
	  -c -o uimenu.o `test -f 'uimenu.c' || echo './'`uimenu.c; \
	then mv ".deps/uimenu.Tpo" ".deps/uimenu.Po"; \
	else rm -f ".deps/uimenu.Tpo"; exit 1; \
	fi
In file included from uimenu.c:44:
../../../../../src/arch/unix/fullscreenarch.h:52: error: array type has incomplete element type
../../../../../src/arch/unix/fullscreenarch.h:53: error: array type has incomplete element type
make[7]: *** [uimenu.o] Error 1

Change History (5)

comment:1 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:2 Changed 11 years ago by bumens@…

Maybe this can help:

<http://vicekb.trikaliotis.net/20-017>

PROBLEMEXPOSITION

If you try to compile VICE for an AMD64/EM64 machine, or you use gcc 4.0, the build fails.

CAUSE

gcc 4.0 is much more picky about the C code.

SOLUTION

Get the patches from the Debian bug tracking system #300936 and #295108. The next version of VICE will contain fixes for these issues - not necessarily the same as provided by the debian bug tracking.

STATUS

The VICE team has confirmed this to be a problem in the VICE versions listed at the beginning of this article. It has been corrected in all subsequent versions

LINKS

  • Debian bug tracking system #300936.
  • Debian bug tracking system #295108.

comment:3 Changed 11 years ago by bumens@…

BTW: The newest VICE version is 2.1, not 1.14. Maybe there is a problem with fetching the wrong package.

comment:4 Changed 11 years ago by bumens@…

There is a patch for 1.14 for 64bit archs:

http://www.viceteam.org/online/vice64bit.diff.gz

comment:5 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: wontfix
Status: newclosed

This problem has existed for over 10 months, and nobody's cared enough to fix it. Removing the package in r61866 ...

If someone wants to put together a new port for the 2.1 version, please do so, but since it's a new major version, it's best to "start from scratch" ... I'll be happy to be the one to commit the new Portfile if someone puts it together (just assign the bug to me).

Note: See TracTickets for help on using tickets.