Opened 12 years ago

Closed 12 years ago

#18719 closed enhancement (wontfix)

port should keep debug output when an action ends in error

Reported by: blb@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.7.0
Keywords: debug log Cc: enl@…
Port:

Description

Currently, if someone runs a command without debug/verbose (eg, sudo port install python26), and it runs into an error, port will only print a limited number of lines. Quite frequently the key line causing the issue is further back than what port keeps.

Will attach some patches which attempt to keep all debug output in a temp file, which is deleted when port is successful, but when port fails, it tells the user to see that log file.

One issue is that the exit status will be 0 even on error unless you use -x, which is ticket #13918.

Note also that the macports.tcl patch simplifies the default ui_init some and actually fixes it for multiple channels (which appears to not be used as it doesn't work currently).

Attachments (2)

macports.tcl.diff (1.8 KB) - added by blb@… 12 years ago.
diff to macports1.0/macports.tcl
port.tcl.diff (1.3 KB) - added by blb@… 12 years ago.
diff to port/port.tcl

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by blb@…

Attachment: macports.tcl.diff added

diff to macports1.0/macports.tcl

Changed 12 years ago by blb@…

Attachment: port.tcl.diff added

diff to port/port.tcl

comment:1 Changed 12 years ago by blb@…

(updated port.tcl.diff to not have issues if a command is run which never generates a debug log)

comment:2 Changed 12 years ago by blb@…

After a few days use, the biggest issue with this is Ctrl-C, since that keeps the log around without saying anything; at least in /tmp it's cleaned on reboots.

comment:3 Changed 12 years ago by jmroot (Joshua Root)

Cc: enl@… added

Is it appropriate for this to be targeted at 1.8? How much does enl's work overlap with or supersede these patches?

comment:4 Changed 12 years ago by blb@…

Milestone: MacPorts 1.8.0
Resolution: wontfix
Status: newclosed

Nah, this can actually be closed in favor of enl's work, since this was just a quick method to at least get something available quickly to avoid "please use -d"...

Note: See TracTickets for help on using tickets.