Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#18725 closed defect (duplicate)

pgplot fails to build on OS X 10.5.6

Reported by: joe@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: pgplot

Description

When trying to install pgplot the following error message occurs during the building step:

---> Building pgplot Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_pgplot/work/pgplot/build" && make all " returned error 2 Command output: /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:90: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:93: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:94: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:95: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:97: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:98: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:99: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:100: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:102: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:103: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLHandle.h:104: error: expected ';' before 'attribute' In file included from /System/Library/Frameworks/Foundation.framework/Headers/Foundation.h:88,

from ../drivers/aqdriv.m:1:

/System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:75: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:76: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:77: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:78: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:83: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:84: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:85: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:88: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:89: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURL.h:91: error: expected ';' before 'attribute' In file included from /System/Library/Frameworks/Foundation.framework/Headers/Foundation.h:127,

from ../drivers/aqdriv.m:1:

/System/Library/Frameworks/Foundation.framework/Headers/NSURLConnection.h:126: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLConnection.h:132: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLConnection.h:153: error: expected ';' before 'attribute' /System/Library/Frameworks/Foundation.framework/Headers/NSURLConnection.h:154: error: expected ';' before 'attribute' make: * [aqdriv.o] Error 1

Error: Status 1 encountered during processing.

Change History (4)

comment:1 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Owner: changed from macports-tickets@… to mcalhoun@…
Status: newassigned

comment:2 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: duplicate
Status: assignedclosed

This is a duplicate of #14494.
Unfortunately, I am unable to add reported to CC of older ticket.
Please add yourself for any updates.

comment:3 in reply to:  2 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Replying to mcalhoun@…:

Unfortunately, I am unable to add reported to CC of older ticket.

Please ignore.
Reporter added to CC of older ticket.

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.