Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#18733 closed update (fixed)

Update several i386-mingw32 ports

Reported by: blb@… Owned by: landonf@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc:
Port: i386-mingw32-w32api i386-mingw32-runtime i386-mingw32-binutils i386-mingw32-gcc

Description

Attached are patches to update several cross/i386-mingw32 ports:

  • i386-mingw32-w32api to version 3.13, switch pre-extract phase to use extract.mkdir, and indicate it violates the mtree
  • i386-mingw32-runtime to version 3.15.2, switch pre-extract phase to use extract.mkdir, and indicate it violates the mtree
  • i386-mingw32-binutils to version 2.19.1 (note that files/patch-configure.diff can be removed)
  • i386-mingw32-gcc to version 3.4.5-20060117-2

Attachments (4)

i386-mingw32-binutils.diff (1.5 KB) - added by blb@… 11 years ago.
i386-mingw32-binutils Portfile diff
i386-mingw32-gcc.diff (2.0 KB) - added by blb@… 11 years ago.
i386-mingw32-gcc Portfile diff
i386-mingw32-runtime.diff (1.2 KB) - added by blb@… 11 years ago.
i386-mingw32-runtime Portfile diff
i386-mingw32-w32api.diff (1.1 KB) - added by blb@… 11 years ago.
i386-mingw32-w32api Portfile diff

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by blb@…

Attachment: i386-mingw32-binutils.diff added

i386-mingw32-binutils Portfile diff

Changed 11 years ago by blb@…

Attachment: i386-mingw32-gcc.diff added

i386-mingw32-gcc Portfile diff

Changed 11 years ago by blb@…

Attachment: i386-mingw32-runtime.diff added

i386-mingw32-runtime Portfile diff

Changed 11 years ago by blb@…

Attachment: i386-mingw32-w32api.diff added

i386-mingw32-w32api Portfile diff

comment:1 Changed 11 years ago by landonf@…

Nice -- please feel free to commit the changes.

comment:2 Changed 11 years ago by blb@…

Resolution: fixed
Status: newclosed

i386-mingw32-w32api in r47659, i386-mingw32-runtime in r47660, i386-mingw32-binutils in r47661, and i386-mingw32-gcc in r47662.

FYI, for i386-mingw32-gcc, the download for g++ uses gcc-g%2B%2B since the plus signs appear not to work with sourceforge...

comment:3 in reply to:  2 ; Changed 11 years ago by ryandesign (Ryan Schmidt)

Replying to blb@…:

FYI, for i386-mingw32-gcc, the download for g++ uses gcc-g%2B%2B since the plus signs appear not to work with sourceforge...

I don't like this because now the file on our distfiles mirror has those %2B's in its name:

http://distfiles.macports.org/i386-mingw32-gcc/

And to download the file the link is now:

http://distfiles.macports.org/i386-mingw32-gcc/gcc-g%252B%252B-3.4.5-20060117-2-src.tar.gz

I note that "port distfiles" says the correct link is:

http://distfiles.macports.org/i386-mingw32-gcc/gcc-g%2B%2B-3.4.5-20060117-2-src.tar.gz

And that of course does not exist. So we appear to have a bug in MacPorts base that does not properly percent-encode distfile names before appending them to the master_sites URL.

comment:4 in reply to:  3 ; Changed 11 years ago by blb@…

Replying to ryandesign@…:

I note that "port distfiles" says the correct link is:

http://distfiles.macports.org/i386-mingw32-gcc/gcc-g%2B%2B-3.4.5-20060117-2-src.tar.gz

And that of course does not exist. So we appear to have a bug in MacPorts base that does not properly percent-encode distfile names before appending them to the master_sites URL.

Hmm, it seems we're in encoding hell...g++ works for other ports (see gcc43 for example), but if you try to grab the g++ from sourceforge even with curl, it isn't there (and probably the cause of ticket #18628). At least in this case, port should be able to successfully get it from sourceforge until we find the cause; new ticket?

comment:5 in reply to:  4 Changed 11 years ago by ryandesign (Ryan Schmidt)

Replying to blb@…:

new ticket?

Yes: #18736.

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Type: enhancementupdate

comment:7 Changed 10 years ago by (none)

Milestone: Port Updates

Milestone Port Updates deleted

Note: See TracTickets for help on using tickets.