Opened 12 years ago

Closed 11 years ago

#18821 closed defect (duplicate)

XLib Problems with GnuCash

Reported by: iThinkergoiMac@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port: gnucash

Description (last modified by jmroot (Joshua Root))

So I've been trying to get GnuCash to install on my PBG4 running Leopard 10.5.6 (1.25 GHz, FW800). It won't launch at all by typing "gnucash" in an xterm, and "gnucash-bin" seems to get it halfway there. X11 launches and the splash screen starts loading but the xterm gives me this:

wxx-xxxxxxxxx-powerbook-g4-15:~ wxxxxxxa$ gnucash-bin
gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

Xlib:  extension "Generic Event Extension" missing on display "/tmp/launch-dECgAE/:0".
Xlib:  extension "RANDR" missing on display "/tmp/launch-dECgAE/:0".
Xlib:  extension "Generic Event Extension" missing on display "/tmp/launch-dECgAE/:0".
Xlib:  extension "Generic Event Extension" missing on display "/tmp/launch-dECgAE/:0".
Xlib:  extension "Generic Event Extension" missing on display "/tmp/launch-dECgAE/:0".
Abort trap

Not sure what to do here... saw a similar bug but the guy said he fixed it by updating. I'm already at the latest version. I've got financial data from my Linux machine, so I was hoping to use this when I upgraded to a Mac.

Change History (8)

comment:1 Changed 12 years ago by iThinkergoiMac@…

Cc: iThinkergoiMac@… added

Cc Me!

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Cc: iThinkergoiMac@… removed
Description: modified (diff)

This does look exactly the same as #18751. Have you upgraded everything outdated?

comment:3 Changed 12 years ago by iThinkergoiMac@…

I believe so... I have run "sudo port -v selfupdate" more times than I can remember and it always says nothing is out of date... unless I'm missing something, everything is up to date. I did see the ticket you referenced but, like I said, I've already got everything up to date...

Thanks for fixing the post and removing the Cc... I realized my mistake on the Cc and couldn't find a code setting to make it clearer.

comment:4 Changed 12 years ago by blb@…

Note that when 'sudo port selfupdate' says The MacPorts installation is not outdated so it was not updated that is about the base MacPorts version; it also does a sync which updates all the Portfiles on your system to be the latest available from the MacPorts server. To see if that sync updated a port you have installed, use 'port outdated' to see which ports you have installed that are now in need of an upgrade.

comment:5 Changed 12 years ago by blb@…

FYI, gnucash has also be updated to 2.2.9 in r48172.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:7 Changed 12 years ago by blb@…

Note, you should use gnucash to run, not gnucash-bin as the former is a script which sets up necessary environment variables.

comment:8 Changed 11 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Calling this a dupe of #18751.

Note: See TracTickets for help on using tickets.