Opened 9 years ago

Closed 8 years ago

#18859 closed enhancement (fixed)

freetype-2.3.9 always use /..namedfork/rsrc for resource forks

Reported by: blb@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc:
Port: freetype

Description

Attached is a patch to print/freetype which changes the way it accesses resources forks, by always using /..namedfork/rsrc instead of the old /rsrc. This should get rid of the occasional system log entries like

kernel[0]: Arial/rsrc: file access by '/rsrc' was deprecated in 10.4

Patch is rooted in print/freetype and updates the Portfile and adds files/patch-src_base_ftrfork.c.diff.

Note, I'm not sure if /..namedfork/rsrc works on 10.3, so if it doesn't this should only be applied for 10.4+.

Attachments (1)

freetype.diff (1.7 KB) - added by blb@… 9 years ago.
diff to freetype

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by blb@…

diff to freetype

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Have you already reported this issue to the developers of freetype? If not, I can do so.

comment:2 Changed 9 years ago by blb@…

I haven't, since it is only a warning (though been bugging me for a while) and I wasn't sure how far back they want to be supporting, OS-version-wise.

comment:3 Changed 9 years ago by anonymous

  • Milestone Port Enhancements deleted

Milestone Port Enhancements deleted

comment:4 Changed 8 years ago by ryandesign (Ryan Schmidt)

Sorry, I forgot this ticket. Can you tell me how to reproduce the problem that your patch fixes?

comment:5 Changed 8 years ago by blb@…

Simply running

${prefix}/bin/fc-cache -f

should result in (at least on 10.6.2) the following in /var/log/kernel.log (and many more lines):

Dec  8 19:41:25 ninagal kernel[0]: hfs: font0419.spd/rsrc: file access by '/rsrc' was deprecated in 10.4

Other OS versions may log to console or system instead.

comment:6 Changed 8 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, I see that now in kernel.log. (I was looking in system.log before.) Committed in r61335.

Note: See TracTickets for help on using tickets.