Opened 12 years ago

Closed 11 years ago

#18912 closed defect (invalid)

kdelibs4 4.2.0_0 requires qt4-mac compiled with -fvisibility=hidden

Reported by: snowflake (Dave Evans) Owned by: illogic-al@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: kdelibs4 -fvisibily=hidden Cc: erickt@…, clubjuggler@…
Port: kdelibs4

Description

While building kdelibs4, I get this error

-- Building kdelibs...
CMake Error at cmake/modules/FindKDE4Internal.cmake:1053 (message):
  Qt compiled without support for -fvisibility=hidden.  This will break
  plugins and linking of some applications.  Please fix your Qt installation.
Call Stack (most recent call first):
  CMakeLists.txt:33 (find_package)


-- Configuring incomplete, errors occurred!

I get an identical error with kdebase4, kdepimlibs4 and phonon

I have tried rebuilding qt4-mac to no avail.

Attachments (1)

bug (3.6 KB) - added by snowflake (Dave Evans) 12 years ago.
log of compilation

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by snowflake (Dave Evans)

Attachment: bug added

log of compilation

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Cc: erickt@… clubjuggler@… added
Owner: changed from macports-tickets@… to illogic-al@…

comment:2 Changed 12 years ago by snowflake (Dave Evans)

I rebuilt qt4-mac with ccache disabled in macports.conf, and now kdelibs4 compiles and installs.

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:4 Changed 11 years ago by illogic-al@…

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.