Opened 12 years ago

Closed 11 years ago

#19147 closed defect (worksforme)

Error building xorg-libice when previous version is active

Reported by: maggesi@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: xorg-libice

Description

Environment: macport 1.710, OSX 10.5.6, on a macbook i386 32bit (Intel Core Duo)

During the compilation of xorg-libice I get the following error:

/usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I/opt/local/include -I../include -I/opt/local/include -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/opt/local/include -DICE_t -DTRANS_CLIENT -DTRANS_SERVER -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -O2 -MT register.lo -MD -MP -MF .deps/register.Tpo -c register.c  -fno-common -DPIC -o .libs/register.o
register.c:48: error: conflicting types for 'IceRegisterForProtocolSetup'
/opt/local/include/X11/ICE/ICElib.h:220: error: previous declaration of 'IceRegisterForProtocolSetup' was here
register.c:148: error: conflicting types for 'IceRegisterForProtocolReply'
/opt/local/include/X11/ICE/ICElib.h:235: error: previous declaration of 'IceRegisterForProtocolReply' was here
make[2]: *** [register.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Thanks for your support. M.

Change History (12)

comment:1 Changed 12 years ago by maggesi@…

Cc: maggesi@… added

Cc Me!

comment:2 Changed 12 years ago by mf2k (Frank Schima)

Cc: mvfranz@… added; maggesi@… removed

What version of Xcode are you running? Please update to version 3.1.2 if you are below that.

comment:3 Changed 12 years ago by jmroot (Joshua Root)

Cc: mvfranz@… removed
Owner: changed from macports-tickets@… to mvfranz@…

comment:4 Changed 12 years ago by mvfranz@…

I was able to upgrade to version 1.0.5 (I had 1.0.4 installed) using OS X 10.4.11 and Xcode 2.5 using MacPorts 1.710. I was also able to install version 1.0.5 using OS X 10.5.6 and Xcode 3.1.2 using both MacPorts 1.700 and 1.710.

comment:5 in reply to:  2 Changed 12 years ago by maggesi@…

Replying to macsforever2000@…:

What version of Xcode are you running? Please update to version 3.1.2 if you are below that.

I upgraded Xcode to 3.1.2. But I get the same error. Is there a way to reinstall the ports that xorg-libice depends on?

comment:6 Changed 12 years ago by mf2k (Frank Schima)

You would have to manually reinstall any dependents. If you haven't already, try this first:

sudo port clean xorg-libice
sudo port install xorg-libice

comment:7 Changed 12 years ago by selecter@…

I get this too with both xcode 3.0 and 3.1.2.

I even tried building it with gcc-4.2.

comment:8 Changed 12 years ago by frstan@…

I get the same error os 10.5.6 on mac mini intel core duo, current xcode.

comment:9 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:10 Changed 12 years ago by kthenriksson@…

I got the same error too. What I needed to do was deactivate the old xorg-libice, and then I could install the new one. In other words, running

sudo port deactivate xorg-libice
sudo port upgrade xorg-libice

should clear this up for anyone.

As far as technical details, the problem is that the old version of xorg-libice and the new one have differing prototypes for the two functions IceRegisterForProtocolSetup and IceRegisterForProtocolReply. One thinks authNames should be a char and the other thinks it should be a const char. As long as the old version is active, the compiler will read in both definitions and then will be uncertain which is correct. So just deactivate the old and all will be well.

comment:11 Changed 11 years ago by ryandesign (Ryan Schmidt)

Owner: changed from mvfranz@… to jeremyhu@…
Summary: Error building xorg-libiceError building xorg-libice when previous version is active

Jeremy H took over this port in r56677.

comment:12 Changed 11 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: worksforme
Status: newclosed

This is probably fixed. Please reopen if you still have issues.

Note: See TracTickets for help on using tickets.