Opened 12 years ago

Closed 11 years ago

#19171 closed defect (fixed)

pango renders some fonts incorrectly

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: font Cc:
Port: pango firefox-x11 freetype

Description (last modified by jeremyhu (Jeremy Huddleston Sequoia))

I noticed that some fonts in firefox-x11 render incorrectly. I narrowed it down to a simple test case:

$ fc-match Fixed
12x13ja.pcf.gz: "Fixed" "ja"

$pango-view --font="Fixed" /etc/passwd
# See garbled cruft in the view

$  fc-match Fixed:style=Regular
7x13.pcf.gz: "Fixed" "Regular"

$pango-view --font="Fixed:Style=Regular" /etc/passwd
# See an expected render

It looks like we need some logic in the config file to prefer style=Regular if no style is designated

Change History (12)

comment:2 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Interesting... the rendering problem is because of the font "Fixed".

$ pango-view --font=Fixed Portfile

But that produces no warning message

You can see the problem in Firefox by:

  • Edit->Preferences->Content->Fonts/Advanced
  • Deselect 'Allow pages to choose their own fonts'
  • Choose 'Fixed' as the monospace font (bad)
  • Choose 'Courier' as the monospace fong (good)

comment:3 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

And it looks like the GSOP problem is caused by helvetica of all fonts:

$ pango-view --font="Helvetica" /tmp/txt (pango-view:56595): Pango-WARNING : Error loading GDEF table 0x6EAD (pango-view:56595): Pango-WARNING : Error loading GSUB table 0x6EAD (pango-view:56595): Pango-WARNING : Error loading GPOS table 0x6EAD

comment:4 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

I filed the helvetica 0x6EAD upstream: http://bugzilla.gnome.org/show_bug.cgi?id=577952

So lets focus back on the rendering issue with fixed.

$ fc-match Fixed 12x13ja.pcf.gz: "Fixed" "ja"

So for some reason it looks like it's prefering this japanese font instead of english .. ?

comment:5 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

And on linux:

$ fc-match Fixed
console9x15.pcf: "Fixed" "Regular"

$  fc-list --verbose | grep Fixed
MiscFixed:style=Regular
MiscFixed:style=SemiCondensed
MiscFixed:style=Bold
MiscFixed:style=Bold SemiCondensed
Fixed:style=Regular

Back on OSX:

$ fc-list --verbose | grep Fixed
Fixed:style=Bold
Fixed:style=Bold SemiCondensed
Fixed:style=SemiCondensed
Fixed:style=Oblique SemiCondensed
Fixed:style=Oblique
Fixed:style=ko
Fixed:style=ja
Fixed:style=Regular

$  fc-match Fixed:style=Regular
7x13.pcf.gz: "Fixed" "Regular"

# Renders fine (although not fixed-width)
$ pango-view --font="Fixed:Style=Regular" /etc/passwd

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

As you've found in the links above, I've experienced this problem since over a year. I don't know how to fix it.

comment:7 Changed 12 years ago by ryandesign (Ryan Schmidt)

"Error loading GDEF table 0x6EAD" was fixed by updating pango to 1.24.1.

comment:8 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

Yeah, the GDEF issue is corrected, but the other issue is not (it turns out they were unrelated... see comment #4, sorry for the 2-for-1 bug report, but I thought they were related when reporting)

The main issue here is the fontconfig match problem.

$ fc-match Fixed 12x13ja.pcf.gz: "Fixed" "ja"

$pango-view --font="Fixed" /etc/passwd # See garbled cruft in the view

$ fc-match Fixed:style=Regular 7x13.pcf.gz: "Fixed" "Regular"

$pango-view --font="Fixed:Style=Regular" /etc/passwd # See an expected render

It looks like we need some logic in the config file to prefer style=Regular if no style is designated

comment:9 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Description: modified (diff)
Resolution: fixed
Status: closedreopened

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:11 Changed 11 years ago by jmroot (Joshua Root)

Does this still happen with 1.28.3?

comment:12 Changed 11 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: reopenedclosed

This seems to have been fixed upstream some time ago: http://bugzilla.gnome.org/show_bug.cgi?id=540617

Current versions in MacPorts look good.

Note: See TracTickets for help on using tickets.