Opened 12 years ago

Closed 12 years ago

#19189 closed defect (duplicate)

ATLAS 3.8.2 gets compiled for 64bit on some architectures

Reported by: max@… Owned by: ajb78@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: atlas 64bit 32bit Cc:
Port: atlas

Description

On architectures where the ATLAS build script detects 64bit support it compiles ATLAS as a 64bit library. This results in linking errors when linked to from other ports, as those are compiled in 32bit.

When configure is called with the '-b 32' flag, a 32bit compilation is forced. I'm not sure what the way to proceed is, my simple patch just adds the -b 32 flag to configure.args

Attachments (1)

atlas-Portfile.diff (673 bytes) - added by max@… 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by max@…

Attachment: atlas-Portfile.diff added

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to ajb78@…

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:3 Changed 12 years ago by tobypeterson

Resolution: duplicate
Status: newclosed

Looks like a duplicate of #17968, hard to tell without some debugging output.

Note: See TracTickets for help on using tickets.