Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19191 closed defect (fixed)

can't import wx module from py26-wxpython

Reported by: skymoo (Adam Mercer) Owned by: jameskyle@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: michaelld (Michael Dickens), mww@…, jjstickel@…
Port: py26-wxpython

Description

I'm unable to import the wx module after installing py26-wxpython:

$ python2.6
Python 2.6.1 (r261:67515, Apr  4 2009, 15:14:47) 
[GCC 4.0.1 (Apple Inc. build 5490)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named wx
>>> exit()
$ port installed py26-wxpython
The following ports are currently installed:
  py26-wxpython @2.8.9.1_0 (active)
$

the same works for py25-wxpython

Change History (14)

comment:1 Changed 12 years ago by michaelld (Michael Dickens)

Cc: mlk@… added

Cc Me!

comment:2 Changed 12 years ago by cristiano.paris@…

The same for me!

comment:3 in reply to:  2 Changed 12 years ago by cristiano.paris@…

Replying to cristiano.paris@…:

The same for me!

Work-around:

sudo ln -s /opt/local/lib/python2.6/site-packages/wx-2.8-mac-unicode/wx /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages

It should work.

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:5 Changed 12 years ago by jameskyle@…

I dropped wxwidgets version down to 2.8.9 and fixed the path problems.

comment:6 Changed 12 years ago by jameskyle@…

Resolution: fixed
Status: newclosed

comment:7 Changed 12 years ago by michaelld (Michael Dickens)

If not done already, someone needs to downgrade py25-wxpython to 2.8.9.1 from 2.8.9.2 -- same as py26-wxpython currently is. wxPython 2.8.9.2 requires wxWidgets 2.8.10 , while the wxPython 2.8.9.1 requires wxWidgets 2.8.9 .

comment:8 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: mww@… added
Resolution: fixed
Status: closedreopened

comment:9 Changed 12 years ago by ryandesign (Ryan Schmidt)

jameskyle downgraded wxWidgets to 2.8.9 in r52414 and I increased the epoch in r52662.

comment:10 Changed 12 years ago by michaelld (Michael Dickens)

I just did a 'port sync', removed py25-wxpython, updated wxwidgets (to 2.8.9 epoch 1), then tried to reinstall py25-wxpython, which errored out. The version of py25-wxpython is still 2.8.9.2, which requires wxwidgets 2.8.10; hence the erroring out is no surprise. Please revert py25-wxpython to 2.8.9.1 while wxwidgets is at 2.8.9.

comment:11 Changed 12 years ago by jjstickel@…

Cc: jjstickel@… added

Cc Me!

comment:12 Changed 12 years ago by jameskyle@…

downgraded py25-wxpython to 2.8.9.1, compiles and installs for me. Sorry for delay, been out of town for a training seminar.

comment:13 Changed 12 years ago by jameskyle@…

Resolution: fixed
Status: reopenedclosed

comment:14 Changed 12 years ago by michaelld (Michael Dickens)

Thanks!

Note: See TracTickets for help on using tickets.