Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19201 closed defect (fixed)

moria: don't create directory "755"

Reported by: ryandesign (Ryan Schmidt) Owned by: aschenke@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: moria

Description

moria creates a directory called "755" in the current directory when it's installed because of an incorrect xinstall command in the destroot phase. Fix attached.

Attachments (1)

moria.diff (673 bytes) - added by ryandesign (Ryan Schmidt) 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by ryandesign (Ryan Schmidt)

Attachment: moria.diff added

comment:1 Changed 12 years ago by aschenke@…

Resolution: fixed
Status: newclosed

Fixed in r49290.

I couldn't reproduce this problem, but I made the suggested change anyway since it doesn't actually affect the permissions (755 is the default).

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Thanks.

The file gets created wherever the working directory currently is. In the case of moria, that's the source directory, possibly because during the build phase you "cd" there.

$ cd $(port dir moria)
$ svn up -r49289 
U    Portfile
Updated to revision 49289.
$ sudo port destroot
--->  Fetching moria
--->  Verifying checksum(s) for moria
--->  Extracting moria
--->  Applying patches to moria
--->  Configuring moria
--->  Building moria
--->  Staging moria into destroot
$ ls -l work/umoria/
total 216
drwxr-xr-x    2 root  rschmidt     68 Apr  7 08:02 755
-rw-r--r--    1 root  rschmidt  22165 Jul 21  1994 CHANGES
-rw-r--r--    1 root  rschmidt  22142 Jul 21  1994 CHANGES.~1~
-rw-r--r--    1 root  rschmidt  37959 Jul 21  1994 ERRORS
-rw-r--r--    1 root  rschmidt   1835 Jul 21  1994 INSTALL
-rw-r--r--    1 root  rschmidt  51602 Jul 21  1994 OChanges
-rw-r--r--    1 root  rschmidt  55614 Jul 21  1994 OOChanges
-rw-r--r--    1 root  rschmidt   2298 Jul 21  1994 README
drwxr-xr-x    8 root  rschmidt    272 Jul 21  1994 amiga
drwxr-xr-x   14 root  rschmidt    476 Jul 21  1994 atari_st
drwxr-xr-x   18 root  rschmidt    612 Jul 21  1994 doc
drwxr-xr-x   11 root  rschmidt    374 Jul 21  1994 files
drwxr-xr-x   19 root  rschmidt    646 Jul 21  1994 ibmpc
drwxr-xr-x   20 root  rschmidt    680 Jul 21  1994 mac
drwxr-xr-x   13 root  rschmidt    442 Jul 21  1994 misc
-rw-r--r--    1 root  rschmidt  11015 Jul 21  1994 shortnam.sed
drwxr-xr-x   88 root  rschmidt   2992 Apr  7 08:02 source
drwxr-xr-x    4 root  rschmidt    136 Jul 21  1994 unix
drwxr-xr-x   12 root  rschmidt    408 Jul 21  1994 util
drwxr-xr-x   12 root  rschmidt    408 Jul 21  1994 vms
$ 

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.