Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19328 closed defect (fixed)

php5, php5-devel: phpize includes path to gsed

Reported by: ryandesign (Ryan Schmidt) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: jyrkiwahlstedt
Port: php5, php5-devel

Description

phpize appears to include the path to gsed, if gsed is installed at build time, even though gsed is not declared as a dependency:

--->  Fetching php5-yaz
--->  Attempting to fetch yaz-1.0.14.tgz from http://distfiles.macports.org/php5-yaz
--->  Verifying checksum(s) for php5-yaz
--->  Extracting php5-yaz
--->  Configuring php5-yaz
Error: Target org.macports.configure returned: shell command "cd /mp/var/macports/build/_Users_rschmidt_macports_dports_php_php5-yaz/work/yaz-1.0.14 && /mp/bin/phpize" returned error 1
Command output: /mp/bin/phpize: line 60: /mp/bin/gsed: No such file or directory
grep: write error: Broken pipe
/mp/bin/phpize: line 61: /mp/bin/gsed: No such file or directory
grep: write error: Broken pipe
/mp/bin/phpize: line 62: /mp/bin/gsed: No such file or directory
grep: write error: Broken pipe
Configuring for:
PHP Api Version:        
Zend Module Api No:     
Zend Extension Api No:  
/mp/bin/phpize: line 136: /mp/bin/gsed: No such file or directory
autoheader: error: AC_CONFIG_HEADERS not found in configure.in

Error: Status 1 encountered during processing.

php5 and php5-devel should either declare a dependency on gsed, or should not use gsed.

Change History (2)

comment:1 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Fixed php5 and php5-devel in r49862.

php4 did not appear to be affected.

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.