Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19329 closed enhancement (fixed)

New top-level category php

Reported by: ryandesign (Ryan Schmidt) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone: MacPorts 1.8.0
Component: base Version: 1.7.1
Keywords: Cc: alakazam@…
Port:

Description

Add a new top-level category for php modules, both those that are separate pecl modules and those that are part of the php source.

Change History (9)

comment:1 Changed 12 years ago by ryandesign (Ryan Schmidt)

Status: newassigned

Added php directory to ports tree in r49683. Still need to appease lint.

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Fixed lint in r49688.

comment:3 Changed 12 years ago by alakazam@…

Should we move existing php modules into this top level category (I'm asking for php5-eaccelerator in particular).

comment:4 Changed 12 years ago by ryandesign (Ryan Schmidt)

I would like that, yes. I would also like existing php modules to use the php5pecl portgroup, but it's not quite ready yet. Using php5pecl would automatically cause the category to be set to php; you could then use categories-append to add more.

comment:5 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: alakazam@… added

comment:6 Changed 12 years ago by alakazam@…

I would also like existing php modules to use the php5pecl portgroup

Is that adequate for non-pecl ports ?

I'll change the portgroup for php5-eaccelerator and will look into submitting diffs for other modules.

comment:7 Changed 12 years ago by ryandesign (Ryan Schmidt)

Possibly. I did not consider that we have php extension ports that aren't in pecl. You'll have to override the master_sites and homepage but the rest might be ok.

Should the portgroup have a different name? The issue is that there will be ports for extensions that are bundled with the php source and use the php build process, and there will be ports for extensions that have their own source and build process, like those in pecl. So we need two portgroup names that are short and sweet and indicative of their purposes.

comment:8 Changed 12 years ago by alakazam@…

Possibly. I did not consider that we have php extension ports that aren't in pecl. You'll have to override the master_sites and homepage but the rest might be ok.

What else (appart from setting category, master_sites and homepage) does the PortGroup do ?

The following php plugins are not (if I'm not mistaken) in pecl :

  • php5-eaccelerator
  • php5-gtk
  • php5-rrdtool
  • php5-syck
  • php5-xdebug

The other php5-* ports are either PECL extensions or standalone projects akin to phpmyadmin (php5-midgard).

comment:9 Changed 12 years ago by ryandesign (Ryan Schmidt)

The php5pecl portgroup has been split into php5extension and php5peclextension so now you can choose the right portgroup for each port.

Note: See TracTickets for help on using tickets.