Opened 12 years ago

Closed 11 years ago

#19380 closed defect (duplicate)

Missing dependency in py*-wxpython

Reported by: laurent.perrinet@… Owned by: jameskyle@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc: mww@…, jyrkiwahlstedt, michaelld (Michael Dickens)
Port: py-wxpython py25-wxpython py26-wxpython

Description

while compiling py26-wxpython, wxWidgets failed to build:

$ sudo port install py26-wxpython

(....)

ld: library not found for -lwx_macu-2.8
collect2: ld returned 1 exit status
make: *** [/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_wxWidgets/work/wxWidgets-2.8.10/build/lib/libwx_macu_gl-2.8.0.6.0.dylib] Error 1
make: *** Waiting for unfinished jobs....
(cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_wxWidgets/work/wxWidgets-2.8.10/build/lib/; rm -f libwx_macu-2.8.dylib libwx_macu-2.8.0.dylib; ln -s libwx_macu-2.8.0.6.0.dylib libwx_macu-2.8.0.dylib; ln -s libwx_macu-2.8.0.dylib libwx_macu-2.8.dylib)

Error: The following dependencies failed to build: wxWidgets
Error: Status 1 encountered during processing.

so one (dirty) solution is to build the missing wxgtk library

$ sudo port install wxgtk

and then to restart compiling py26-wxpython

Change History (8)

comment:1 Changed 12 years ago by raimue (Rainer Müller)

Cc: mww@… jwa@… added
Owner: changed from macports-tickets@… to jameskyle@…
Port: py-wxpython py25-wxpython py26-wxpython added
Summary: missing dependency in wxWidgetsMissing dependency in py*-wxpython

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:3 Changed 12 years ago by michaelld (Michael Dickens)

Cc: mlk@… added

Cc Me!

comment:4 Changed 12 years ago by michaelld (Michael Dickens)

My installs of wxWidgets 2.8.10 and wxPython 2.8.9.2 (py25 or py26, not both) went without a hitch. If I issue

port provides /opt/local/lib/libwx_macu-2.8.0.dylib

it returns back

/opt/local/lib/libwx_macu-2.8.0.dylib is provided by: wxWidgets

Please note that I do not have wxgtk installed.

comment:5 Changed 11 years ago by jameskyle@…

Owner: changed from jameskyle@… to jameskyle@…

I got the same error as above just now. But then I manually installed wxwidgets since I figured it provided libwx...

After that it installed without a hitch. The Portfile clearly declares wxwidgets as a dependency, so I'm not sure what the problem is. Have yet to reproduce it.

comment:6 Changed 11 years ago by jameskyle@…

Resolution: fixed
Status: newclosed

After a few tests, I think the wxwidgets compile doesn't like parallel builds. It was trying to link to the libwx_macu library before it'd be compiled.

I've added a

use_parallel_build no

To the wxwidgets portfile.

comment:7 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

Ok, then this was a duplicate of #16099.

comment:8 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.