Opened 12 years ago

Closed 12 years ago

#19471 closed defect (fixed)

atk: build failure while installing librsvg

Reported by: djdmsr@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: gtk-doc Cc:
Port: atk

Description (last modified by dbevans (David B. Evans))

Helo Installing librsvg:

Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_atk/work/atk-1.26.0" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_atk/work/destroot " returned error 2
Command output: -- Installing ./html/AtkSelection.html
-- Installing ./html/AtkStateSet.html
-- Installing ./html/AtkStreamableContent.html
-- Installing ./html/AtkTable.html
-- Installing ./html/AtkText.html
-- Installing ./html/AtkUtil.html
-- Installing ./html/AtkValue.html
-- Installing ./html/atk-AtkHyperlinkImpl.html
-- Installing ./html/atk-AtkState.html
-- Installing ./html/atk.devhelp
-- Installing ./html/atk.devhelp2
-- Installing ./html/atk.html
-- Installing ./html/home.png
-- Installing ./html/index.html
-- Installing ./html/index.sgml
-- Installing ./html/ix01.html
-- Installing ./html/ix02.html
-- Installing ./html/ix03.html
-- Installing ./html/ix04.html
-- Installing ./html/ix05.html
-- Installing ./html/ix06.html
-- Installing ./html/ix07.html
-- Installing ./html/left.png
-- Installing ./html/right.png
-- Installing ./html/style.css
-- Installing ./html/up.png
/bin/sh: line 1: gtkdoc-rebase: command not found
make[2]: *** [install-data-local] Error 127
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1

Error: The following dependencies failed to build: libgsf gnome-vfs gconf gtk2 atk gtk-doc docbook-xml-4.3 xmlcatmgr docbook-xsl gnome-doc-utils docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 iso-codes py25-hashlib openssl python25 libxslt p5-xml-parser py25-libxml2 rarian getopt intltool gnome-common jasper pango Xft2 shared-mime-info xorg-libXcomposite xorg-compositeproto xorg-fixesproto xorg-libXfixes xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto orbit2 libidl gnome-mime-data libbonobo
Error: Status 1 encountered during processing.

I'm neewby Thank you for any hepl

Change History (3)

comment:1 Changed 12 years ago by dbevans (David B. Evans)

Description: modified (diff)
Keywords: gtk-doc added
Port: atk added
Summary: librsvg problemsatk: build failure while installing librsvg

First please use wiki formatting when submitting error output like this -- it makes for easier reading. I'm doing it for you this time.

Second the problem is with port atk which is a dependency of librsvg. Have submitted a tentative quick fix in r50324.

Please do the following after waiting an hour or so for the system to update

sudo port selfupdate
sudo port clean atk
sudo port install librsvg

Hope this helps.

comment:2 Changed 12 years ago by djdmsr@…

YESSSSSSSSS lol Thanks you very much I needed librsvg for using nugsl-worldmap: http://gsl-nagoya-u.net/appendix/software/worldmap/ Great script for who like maps Why not add worldmap like a new port?

Regards

comment:3 Changed 12 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Glad its working. Since you're familiar with worldmap, why don't you take a crack at making a Portfile that works for you and then submitting it (via a port submission ticket) for inclusion? Always looking for new ports.

Closing this ticket as fixed

Note: See TracTickets for help on using tickets.