Opened 11 years ago

Closed 8 years ago

#19524 closed update (fixed)

kdiff3 updated to v0.9.95

Reported by: nick@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: kdiff3 update v0.9.95 Cc: dsdale24@…, ak.ml@…, norbert.nemec@…, gleirsch@…
Port: kdiff3

Description

kdiff3 is showing signs of life again, with three updates this year. Updating the port to the latest version, v0.9.95 from v0.9.92, would be great!

Thanks for your hard work.

Attachments (1)

Portfile (1.4 KB) - added by dsdale24@… 11 years ago.
kdiff3-0.9.95 Portfile

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to simon@…

Changed 11 years ago by dsdale24@…

Attachment: Portfile added

kdiff3-0.9.95 Portfile

comment:2 Changed 11 years ago by dsdale24@…

Cc: dsdale24@… added

Cc Me!

comment:3 Changed 11 years ago by dsdale24@…

I took a crack at modifying the old portfile, see attached. This is my first attempt to work with Portfiles, so I suggest my work should be checked by someone knowledgeable, perhaps someone familiar with the kde4 portgroup. The executable appears in /Applications/MacPorts/KDE4/kdiff3.app/Contents/MacOS/kdiff3, but it would be really useful if it also appeared on the path, so kdiff3 could be invoked by tools like git and bzr.

comment:4 Changed 10 years ago by simon@…

Owner: changed from simon@… to macports-tickets@…

comment:5 Changed 9 years ago by ak.ml@…

Cc: ak.ml@… added

Cc Me!

comment:6 Changed 9 years ago by gabriele@…

I don't see the update, and the current version won't install since I have qt4.

$ port search kdiff3 kdiff3 @0.9.92 (devel)

kdiff3 is a file comparing and merging tool.

$ sudo port install kdiff3 ---> Computing dependencies for kdiff3 Error: Unable to execute port: Can't install qt3 because conflicting ports are installed: qt4-mac To report a bug, see <http://guide.macports.org/#project.tickets>

comment:7 Changed 9 years ago by norbert.nemec@…

I see that 0.9.96 has been released. Couldn't get it to compile with this Portfile.

Ideally, I think that kdiff3 should be compiled without kdelibs4, just using qt4-mac. Couldn't get this to work either.

Has anyone succeeded?

comment:8 Changed 9 years ago by norbert.nemec@…

Cc: norbert.nemec@… added

Cc Me!

comment:9 Changed 9 years ago by calvin@…

Cc me

comment:10 Changed 8 years ago by gleirsch@…

No, having the same problem. Does the conflict mean that kdiff3 has to be ported to qt4-mac or to avoid use of qt4 ports instead? Using diffuse in the meanwhile, though not being the ideal alternative :(

comment:11 Changed 8 years ago by gleirsch@…

Cc: gleirsch@… added

Cc Me!

comment:12 Changed 8 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.