Opened 12 years ago

Closed 11 years ago

#19558 closed enhancement (fixed)

py25-shogun - 0.6 - deprecated, should be moved to shogun

Reported by: jameskyle@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: py25-shogun, shogun

Description

I am submitting a new port called shogun. Due to changes in the shogun build process, I am now able to specify multiple interfaces in one build.

Thus, a single port with interface variants is more appropriate. e.g.

port install shogun +python +octave +r

Please see ticket #18557 for the new portfile for pymvpa. The pymvpa port should be concurrently updated as it has a variant for the py25-shogun (now shogun) port.

Attachments (1)

Portfile (2.5 KB) - added by jameskyle@… 12 years ago.
New shogun portfile

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by jameskyle@…

Attachment: Portfile added

New shogun portfile

comment:1 Changed 12 years ago by jameskyle@…

Raim reports:

shogun seems to install the elwms package outside the macports destroot (/elwms instead of $prefix/destination/elwms).

comment:2 Changed 12 years ago by jameskyle@…

I've compiled a fresh 1.8 development install. From a clean ports I did:

port install shogun +r +octave +python

I could not reproduce the elwms destroot error, however I did notice the following "hitches"

  1. gcc43, pulled in by atlas port, fails. Doing a port clean --all gcc43; port install gcc43 resulted in a clean build with no error
  2. Saw a similar problem with R or octave, re-executing port install shogun +r +octave +python resulted in clean build (who knows?)
  3. The swig port provided significant "gotchas" -- pulled in apache2 and all associated deps due to php5 dependency (this is discussed in another ticket and a solution is being worked on) -- default variants do not include octave, thus the octave variant fails. I do not know the most appropriate/recommended way to handle this given the current inability to declare a variant as a dep

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Port: py25-shogun shogun added
Resolution: fixed
Status: newclosed

jameskyle moved py25-shogun to shogun in r52305

Note: See TracTickets for help on using tickets.