Opened 12 years ago

Closed 12 years ago

#19703 closed defect (invalid)

Pango upgrade fails to find X11

Reported by: pony777@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: x11 Cc:
Port: pango

Description

I'm trying to upgrade Pango to version 1.24.2. The build fails. It appears to be having trouble finding X11. The tail end of the log file is:

libtool: link: /usr/bin/grep -E -e "^pango_.*" ".libs/libpangox-1.0.exp" > ".libs/libpangox-1.0.expT"
libtool: link: mv -f ".libs/libpangox-1.0.expT" ".libs/libpangox-1.0.exp"
libtool: link: sed 's,^,_,' < .libs/libpangox-1.0.exp > .libs/libpangox-1.0-symbols.expsym
libtool: link: /usr/bin/gcc-4.0 -dynamiclib  -o .libs/libpangox-1.0.0.dylib  .libs/pangox.o .libs/module-defs-x.o .libs/pangox-fontcache.o .libs/pangox-fontmap.o   -L/opt/local/lib ./.libs/libpango-1.0.dylib -lm /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgmodule-2.0.dylib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib -lc /opt/local/lib/libiconv.dylib -lX11    -framework Carbon -install_name  /opt/local/lib/libpangox-1.0.0.dylib -compatibility_version 2401 -current_version 2401.2 -Wl,-exported_symbols_list,.libs/libpangox-1.0-symbols.expsym
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: can't locate file for: -lX11
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/libtool: file: -lX11 is not an object file (not allowed in a library)
make[4]: *** [libpangox-1.0.la] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
Warning: the following items did not execute (for pango): org.macports.destroot org.macports.build
Error: Unable to upgrade port: 1
Executing: /opt/local/bin/port -v upgrade pango +macosx

Change History (6)

comment:1 Changed 12 years ago by dbevans (David B. Evans)

Keywords: pango removed
Owner: changed from macports-tickets@… to ryandesign@…

Clean the port and then try it without +macosx

sudo port clean pango
sudo port upgrade pango

macosx is a platform variant which is supplied automatically by MacPorts if it is appropriate. Don't use it on the command line.

comment:2 Changed 12 years ago by pony777@…

Tried that. Got the same error. I think this may have something to do with the switchover to having MacPorts provide the X11 libraries. Is there a straightforward explanation of that somewhere? I have a bunch of ports in which the system_x11 variant is selected. That variant seems to have disappeared and I'm confused as to how I'm supposed to have x11 stuff set up.

comment:3 Changed 12 years ago by dbevans (David B. Evans)

That's probably the problem then. I would uninstall at a minimum all of the ports that have +system_x11 selected then clean pango again and try the upgrade. Better but more of a pain would be to uninstall everything and start over again. Make sure you're not setting +system_x11 in ${prefix}/etc/macports/variants.conf by the way or it will just override what you're doing.

comment:4 Changed 12 years ago by jmroot (Joshua Root)

Setting +system_x11 anywhere will not do anything now that no ports have that variant...

comment:5 Changed 12 years ago by dbevans (David B. Evans)

Yes, but he needs to get rid of his existing port that were built with this variant and rebuild them to get things to work properly. My comment about the variants.conf doesn't make any difference now but might be good to remove any mention of +system_x11 there for cleanliness.

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.