Opened 11 years ago

Closed 11 years ago

#19718 closed defect (duplicate)

liblqr build fail

Reported by: christophe.haro@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: christophe.haro@…
Port: liblqr

Description (last modified by tobypeterson)

When I try to upgrade liblqr with this command :

sudo port -u upgrade liblqr

the complete response is :

--->  Fetching liblqr
--->  Verifying checksum(s) for liblqr
--->  Extracting liblqr
--->  Configuring liblqr
--->  Building liblqr
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_liblqr/work/liblqr-1-0.4.1" && make all " returned error 2
Command output: make  all-recursive
Making all in lqr
if /bin/sh ../libtool --tag=CC --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I..  -DDATADIR=\""/opt/local/share/liblqr-1"\" -I.. -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include -fvisibility="hidden" -I/opt/local/include  -O2 -Wall -MT lqr_gradient.lo -MD -MP -MF ".deps/lqr_gradient.Tpo" -c -o lqr_gradient.lo lqr_gradient.c; \
	then mv -f ".deps/lqr_gradient.Tpo" ".deps/lqr_gradient.Plo"; else rm -f ".deps/lqr_gradient.Tpo"; exit 1; fi
libtool: compile:  /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -DDATADIR=\"/opt/local/share/liblqr-1\" -I.. -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include -fvisibility=hidden -I/opt/local/include -O2 -Wall -MT lqr_gradient.lo -MD -MP -MF .deps/lqr_gradient.Tpo -c lqr_gradient.c  -fno-common -DPIC -o .libs/lqr_gradient.o
if /bin/sh ../libtool --tag=CC --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I..  -DDATADIR=\""/opt/local/share/liblqr-1"\" -I.. -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include -fvisibility="hidden" -I/opt/local/include  -O2 -Wall -MT lqr_rwindow.lo -MD -MP -MF ".deps/lqr_rwindow.Tpo" -c -o lqr_rwindow.lo lqr_rwindow.c; \
	then mv -f ".deps/lqr_rwindow.Tpo" ".deps/lqr_rwindow.Plo"; else rm -f ".deps/lqr_rwindow.Tpo"; exit 1; fi
libtool: compile:  /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -DDATADIR=\"/opt/local/share/liblqr-1\" -I.. -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include -fvisibility=hidden -I/opt/local/include -O2 -Wall -MT lqr_rwindow.lo -MD -MP -MF .deps/lqr_rwindow.Tpo -c lqr_rwindow.c  -fno-common -DPIC -o .libs/lqr_rwindow.o
/var/tmp//cccTs8L5.s:33:non-relocatable subtraction expression, "_lqr_carver_read_luma" minus "L00000000001$pb"
/var/tmp//cccTs8L5.s:33:symbol: "_lqr_carver_read_luma" can't be undefined in a subtraction expression
/var/tmp//cccTs8L5.s:19:non-relocatable subtraction expression, "_lqr_carver_read_brightness" minus "L00000000001$pb"
/var/tmp//cccTs8L5.s:19:symbol: "_lqr_carver_read_brightness" can't be undefined in a subtraction expression
make[2]: *** [lqr_rwindow.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1

Change History (3)

comment:1 Changed 11 years ago by tobypeterson

Description: modified (diff)

comment:2 Changed 11 years ago by tobypeterson

Port: @10.4.1 removed
Version: 1.7.1

comment:3 Changed 11 years ago by tobypeterson

Resolution: duplicate
Status: newclosed

duplicate of #19685

Note: See TracTickets for help on using tickets.