Opened 12 years ago

Closed 11 years ago

#19720 closed enhancement (worksforme)

lua-numlua: why depend on gcc43?

Reported by: anddam (Andrea D'Amore) Owned by: bfulgham@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: lua-numlua

Description

Is gcc42 port: dependency really needed in lua-numlua and is there a reason for not having a gcc43 variant too?

Change History (2)

comment:1 Changed 11 years ago by ryandesign (Ryan Schmidt)

Keywords: gcc42 port deps removed
Summary: GCC 4.2 dependencylua-numlua: why depend on gcc43?

lua-numlua now depends on gcc43 as of r57800. The reason it depends on a gcc port at all is because it needs a fortran compiler; Apple doesn't provide one. Variants for different gcc versions could be added; this would be a good idea, even. But the port's current strategy of hardcoding the compiler name in the patchfile would then have to be changed.

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

There doesn't appear to be anything to do here.

Note: See TracTickets for help on using tickets.