Opened 12 years ago

Closed 12 years ago

#19721 closed defect (fixed)

ghc 6.10.3 requires Xcode 3.1.2 on Tiger, but Xcode 3.1.2 requires Leopard

Reported by: gale@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: h8spawn@…
Port: ghc

Description

--->  Fetching ghc
On Mac OS X 10.4, ghc 6.10.3 requires Xcode 3.1.2 but you have Xcode 2.5.

This may have been an attempt to fix #19574, see comments there.

But on the Apple Developer Connection website, the download for XCode 3.1.2 states "...must be installed on Leopard, Mac OS X 10.5.0 and higher." If there is any way to get XCode 3.1.2 for Tiger, please let us know. Otherwise, we need this port to compile with XCode 2.5 for Tiger.

Change History (5)

comment:1 Changed 12 years ago by tobypeterson

Summary: ghc 6.10.3 requires XCode 3.1.2 on Tiger, but XCode 3.1.2 requires Leopardghc 6.10.3 requires Xcode 3.1.2 on Tiger, but Xcode 3.1.2 requires Leopard

comment:2 Changed 12 years ago by h8spawn@…

Cc: h8spawn@… added

Cc Me!

comment:3 Changed 12 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to gwright@…

comment:4 Changed 12 years ago by gale@…

If I was right about the issue being #19574, please note that there is now an upstream patch that is reported to work for Mac OS X 10.4.11 and Xcode 2.5. See comments there.

comment:5 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

The erroneous Xcode version check for Tiger was fixed in r51325. Now the port checks for Xcode 2.5 on Tiger.

Note: See TracTickets for help on using tickets.