Opened 12 years ago

Closed 12 years ago

#19728 closed defect (fixed)

Problem with make policykit

Reported by: info@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: xsltproc Cc:
Port: docbook-xsl

Description (last modified by mf2k (Frank Schima))

Making all in man
/opt/local/bin/xsltproc -nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl polkit-auth.xml
I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"
cannot parse http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl

Change History (6)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to devans@…

comment:2 Changed 12 years ago by dbevans (David B. Evans)

Status: newassigned

I'm not sure what to make of this. I just tried rebuilding the port here and I couldn't reproduce your problem. Make sure you have docbook-xsl installed (it should be as it is a dependency of gnome-doc-utils which is a declared build dependency of this port).

What does

port installed name:docbook

tell you?

Have you tried cleaning the port and trying again?

sudo port clean --all policykit
sudo port install policykit

It looks like it is failing to find docbook.xsl on the net, but it shouldn't be doing that because of the -nonet argument to xsltproc. Should be using the copy supplied by port docbook-xsl.

I'm mistified. Does anyone else understand what's happending here?

A last ditch effort you be to disable building of man pages by adding

--disable-man-pages

to the configure.args in the Portfile

comment:3 Changed 12 years ago by blb@…

Ticket #19784 has some more info which may help.

comment:4 Changed 12 years ago by info@…

tanks i am soluttion this problem, very thanks

comment:5 Changed 12 years ago by jim@…

UPDATE from #19784 -- this is due to breakage in /opt/local/etc/xml/catalog. It's missing a line:

<nextCatalog catalog="/opt/local/share/xsl/docbook-xsl/catalog.xml" />

You could add it manually:

xmlcatmgr add nextCatalog /opt/local/share/xsl/docbook-xsl/catalog.xml

This is supposed to be added by docbook-xsl. I strongly recommend that you uninstall and reinstall it, which fixes this:

sudo port -f uninstall docbook-xsl
sudo port install docbook-xsl

comment:6 Changed 12 years ago by dbevans (David B. Evans)

Keywords: policykit removed
Port: docbook-xsl added; policykit removed
Resolution: fixed
Status: assignedclosed

Thanks for the help on this. Closing this as fixed for now but looks like there may be a problem with docbook-xsl when updating (as opposed to uninstall/install).

Note: See TracTickets for help on using tickets.