Opened 11 years ago

Closed 10 years ago

#19731 closed defect (fixed)

kdenetwork3 @3.5.10_1 Build Failure

Reported by: ctempleton3@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: ctempleton3@…, dtolnay@…
Port: kdenetwork3

Description

I am not able to build kdenetwork3

$ sudo port install kdenetwork3
Portfile changed since last build; discarding previous state.
--->  Fetching kdenetwork3
--->  Verifying checksum(s) for kdenetwork3
--->  Extracting kdenetwork3
--->  Configuring kdenetwork3
--->  Building kdenetwork3
Error: Target org.macports.build returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10 && MAKEFLAGS="-j 1" ./CompileScript.sh" returned error 1
Command output: 85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/krdc/keycapturedialog.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/krdc/kremoteview.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/krdc/preferencesdialog.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/krdc/maindialogwidget.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/krdc/maindialog.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/DirSelectWidget.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/Server.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/WebServer.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/WebServerSocket.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/WebServerManager.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/SingleServerConfigDialog.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/ConfigDialogPage.cpp
85% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/ErrorMessageConfigDialog.cpp
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/ActiveMonitor.cpp
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/ActiveMonitorWindow.cpp
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/BandwidthGraph.cpp
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/BandwidthGraph.cpp: In member function 'void KPF::BandwidthGraph::updateContents()':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/BandwidthGraph.cpp:105: warning: unused variable 'w'
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/ServerWizard.cpp
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/AppletItem.cpp
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/Applet.cpp
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/PropertiesDialogPlugin.cpp
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kpf/src/StartingKPFDialog.cpp
86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp
g++ -DHAVE_CONFIG_H -I./kopete/libkopete/avdevice -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice -I. -I/opt/local/include -I/opt/local/lib/qt3/include -I/usr/X11R6/include -I/opt/local/include -DKDE_NO_COMPAT -DQT_NO_COMPAT -DQT_NO_CAST_ASCII -DQT_NO_ASCII_CAST -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete -I./kopete/libkopete -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/ui -I./kopete/libkopete/ui -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/private -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/ui -I/opt/local/include -I/opt/local/lib/qt3/include -I/usr/X11R6/include -I/opt/local/include -DQT_THREAD_SUPPORT -I/opt/local/include/freetype2 -I/opt/local/include -fno-common -no-cpp-precomp -DMACOSX -DARTS_NO_ALARM -I/opt/local/include -I/usr/X11R6/include -D_LARGE_FILES=1 -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Os -Os -fPIC -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -fvisibility=hidden -fvisibility-inlines-hidden -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -fPIC -DPIC -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp -o ./kopete/libkopete/avdevice/.libs/qvideostream.o -Wp,-MD,./kopete/libkopete/avdevice/.deps/qvideostream.TUlo
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp: In member function 'virtual void QVideoStreamGLWidget::initializeGL()':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp:582: error: invalid conversion from 'int*' to 'GLint*'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp:582: error:   initializing argument 2 of 'void glGetIntegerv(GLenum, GLint*)'
Error creating ./kopete/libkopete/avdevice/qvideostream.lo. Exit status 1.
kdenetwork3-3.5.10-1 make failed!

Error: Status 1 encountered during processing.
$

Please do not remove me a CC'ed on this ticket.

Change History (6)

comment:1 Changed 11 years ago by gargasm@…

i'm getting the same error.

86% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp
g++ -DHAVE_CONFIG_H -I./kopete/libkopete/avdevice -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice -I. -I/opt/local/include -I/opt/local/lib/qt3/include -I/usr/X11R6/include -I/opt/local/include -DKDE_NO_COMPAT -DQT_NO_COMPAT -DQT_NO_CAST_ASCII -DQT_NO_ASCII_CAST -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete -I./kopete/libkopete -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/ui -I./kopete/libkopete/ui -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/private -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/ui -I/opt/local/include -I/opt/local/lib/qt3/include -I/usr/X11R6/include -I/opt/local/include -DQT_THREAD_SUPPORT -I/opt/local/include/freetype2 -I/opt/local/include -fno-common -no-cpp-precomp -DMACOSX -DARTS_NO_ALARM -I/opt/local/include -I/usr/X11R6/include -D_LARGE_FILES=1 -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Os -Os -fPIC -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -fvisibility=hidden -fvisibility-inlines-hidden -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -fPIC -DPIC -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp -o ./kopete/libkopete/avdevice/.libs/qvideostream.o -Wp,-MD,./kopete/libkopete/avdevice/.deps/qvideostream.TUlo
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp: In member function 'virtual void QVideoStreamGLWidget::initializeGL()':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp:582: error: invalid conversion from 'int*' to 'GLint*'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp:582: error:   initializing argument 2 of 'void glGetIntegerv(GLenum, GLint*)'
Error creating ./kopete/libkopete/avdevice/qvideostream.lo. Exit status 1.
kdenetwork3-3.5.10-0 make failed!

here's my system:

Darwin tiPop.local 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc

comment:2 Changed 10 years ago by dtolnay@…

Sorry this is a bit late. I ran into the same problem today.

Here is the fix:

sudo nano +64 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdenetwork3/work/kdenetwork-3.5.10/kopete/libkopete/avdevice/qvideostream.cpp

Change "int _maxGL;" to read "GLint _maxGL;"

comment:3 Changed 10 years ago by dtolnay@…

Cc: dtolnay@… added

Cc Me!

comment:4 Changed 10 years ago by takanori@…

Which version of Mac OS X are you using?

I couldn't reproduce this problem on Snow Leopard.

comment:5 Changed 10 years ago by dtolnay@…

Tiger (10.4.11) on a Macbook Pro 3,1

*$ uname -a Darwin *.local 8.11.1 Darwin Kernel Version 8.11.1: Wed Oct 10 18:23:28 PDT 2007; root:xnu-792.25.20~1/RELEASE_I386 i386 i386

comment:6 Changed 10 years ago by takanori@…

Resolution: fixed
Status: newclosed

Okay. Probably this is a tiger-only problem.

I have committed your suggested patch in r62882, so I think this problem should be fixed now.

Thank you for reporting!

Note: See TracTickets for help on using tickets.