Opened 11 years ago

Closed 10 years ago

#19742 closed defect (duplicate)

help2man fails. prevents firefox-x11

Reported by: jross@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: help2man

Description

help2man fails with the following error:

--->  Staging help2man into destroot
Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.36.4" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot " returned error 2
Command output: ./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/bin
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/lib
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/man/man1
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info
/usr/bin/install -c help2man /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/bin
/usr/bin/install -c -m 644 ./help2man.1 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/man/man1
/usr/bin/install -c -m 644 ./help2man.info \
    /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info/help2man.info
if test -f /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info/dir; \
then \
    /usr/bin/install-info --info-dir=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info \
        ./help2man.info; \
fi
/usr/bin/gcc-3.3  -o hacklocaledir.so -fPIC -bundle hacklocaledir.c 
hacklocaledir.c: In function `__open':
hacklocaledir.c:44: error: `RTLD_NEXT' undeclared (first use in this function)
hacklocaledir.c:44: error: (Each undeclared identifier is reported only once
hacklocaledir.c:44: error: for each function it appears in.)
hacklocaledir.c: At top level:
hacklocaledir.c:113: warning: weak declaration of `open' not supported
hacklocaledir.c:113: warning: alias definitions not supported in this configuration; ignored
make: *** [hacklocaledir.so] Error 1

Error: The following dependencies failed to build: xulrunner esound audiofile libtool automake autoconf help2man m4 gconf dbus-glib dbus xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-libXdmcp xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libsm xorg-libice glib2 gtk2 atk gtk-doc docbook-xml-4.3 xmlcatmgr docbook-xsl gnome-doc-utils docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 iso-codes py25-hashlib openssl python25 libxml2 libxslt p5-xml-parser py25-libxml2 rarian getopt intltool gnome-common cairo fontconfig freetype gmake libpixman libpng xrender xorg-renderproto jasper pango Xft2 shared-mime-info tiff xorg-libXcomposite xorg-compositeproto xorg-libXext xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto orbit2 libidl policykit heimdal lcms libcanberra gstreamer bison flex gzip libvorbis libogg nspr nss sqlite3 xorg-libXt xorg-util-macros
Error: Status 1 encountered during processing.

Change History (7)

comment:1 Changed 11 years ago by jross@…

Cc: jross@… added

Cc Me!

comment:2 Changed 11 years ago by mf2k (Frank Schima)

Cc: jross@… removed

What version of Mac OS X are you running? What version of Xcode?

comment:3 Changed 11 years ago by jross@…

OS X 10.3.9

XCode: I downloaded the latest I could get when I installed macports. 1.5, IIRC.

Thanks!

comment:4 Changed 11 years ago by mf2k (Frank Schima)

Resolution: wontfix
Status: newclosed

I suggest upgrading your OS to Leopard and Xcode 3.1.2. We don't have the resources to support Panther. However, if you can supply a patch, it will likely get committed.

comment:5 Changed 11 years ago by jross@…

If I could upgrade to Leopard I wouldn't be using macports for firefox, would I?

Thanks.

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: wontfix
Status: closedreopened

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: reopenedclosed

Actually a duplicate of #12336.

Note: See TracTickets for help on using tickets.