Opened 12 years ago

Closed 12 years ago

#19792 closed defect (fixed)

hdf5/hdf5-18 conflict

Reported by: jjstickel@… Owned by: alakazam@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: hdf5 octave ipython netcdf Cc: mamoll (Mark Moll), jochen@…, alakazam@…, stechert@…, tenomoto (Takeshi Enomoto)
Port: hdf5 hdf5-18

Description

Octave depends on hdf5 but (py25-)ipython depends on hdf5-18 (via netcdf as of netcdf@4.0_1). Since hdf5 conflicts with hdf5-18, it is not possible to have octave and ipython installed simultaneously. Possible solutions are to make octave dependent on hdf5-18 or to revert netcdf dependency to hdf5.

Change History (6)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: mmoll@… jochen@… added
Port: hdf5 hdf5-18 added

comment:2 Changed 12 years ago by jochen@…

Cc: alakazam@… stechert@… added
Keywords: netcdf added

Well, let's move forward and have octave use hdf5-18 as well...

comment:3 Changed 12 years ago by alakazam@…

Owner: changed from macports-tickets@… to alakazam@…
Status: newassigned

Sure ! I'll look into this shortly.

comment:4 Changed 12 years ago by jjstickel@…

Octave 3.2.0 was released last week. Might as well up the version of the Octave port in addition to adjusting the hdf5 dependency.

comment:5 Changed 12 years ago by tenomoto (Takeshi Enomoto)

Cc: takeshi@… added

Cc Me!

comment:6 Changed 12 years ago by alakazam@…

Resolution: fixed
Status: assignedclosed

octave dependency updated in r52711.

Note: See TracTickets for help on using tickets.