Opened 8 years ago

Closed 8 years ago

#19801 closed defect (invalid)

Can't build gmp 4.3.1

Reported by: chredwpea@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: chredwpea@…


I read the FAQ. I have the latest xcode and checked that ports was updated and upgraded.

I get this error:

chrep-mac:~ chrep$ sudo port install gmp ---> Configuring gmp Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gmp/work/gmp-4.3.1" && ./configure --prefix=/opt/local --infodir=/opt/local/share/info --enable-cxx " returned error 1 Command output: sh: line 0: cd: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gmp/work/gmp-4.3.1: No such file or directory

Error: Status 1 encountered during processing.

If I check the directory in question, there is a gmp-4.2.4 subdirectory but no other directory. No Unix guru here and just getting feet wet for first time with ports; hope this isn't PEBCAK.

Change History (4)

comment:1 Changed 8 years ago by chredwpea@…

  • Cc chredwpea@… added

Cc Me!

comment:2 Changed 8 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

  • Owner changed from macports-tickets@… to mcalhoun@…
  • Status changed from new to assigned


I am not sure why the gmp-4.2.4 subdirectory is the wrong version.
Could you please try

sudo port clean gmp
sudo port install gmp

If you still get an error message, could you post it using WikiFormatting.

comment:3 Changed 8 years ago by chredwpea@…


sudo port clean

followed by a

sudo port install


I don't know why the 4.2.4 version would be there already. The only factor I can think of is that my actual goal was to install the Haskell interpreter ghc. I ran that install first and it identified the gmp dependency.

Perhaps the Haskell package somehow created a stub for gmp? That doesn't seem right to me, but I am literally a first-day user of macports and I therefore should be in a completely clean environment.

Thank you very much for your help! GHC is in progress installing now. -fingers crossed-

comment:4 Changed 8 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

  • Resolution set to invalid
  • Status changed from assigned to closed

I am glad it is working.

If you started then stopped an installation of gmp through ghc, updated the ports, then installed gmp manually,
then perhaps that is the reason for the problem.
Just a guess.

I am curious why you originally tried to install gmp manually (sudo port install gmp).
Installing a package (such as ghc) should install all dependencies automatically without you having to install them yourself.

I hope MacPorts proves to be a useful tool for you.

Note: See TracTickets for help on using tickets.